Problems with Amazon Rekognition from HACS

I’ve used this integration for a while without any problems. I was on HA .110, so I went to .111, .112, and finally .113. Now my rekognition image processing entities all show their state as “unknown”. They stopped working during one of those updates. I’ve updated HACS to the most current version. I’ve tried downgrading rekognition from 2.6 to 2.5, 2.4, and 2.3, but the entities still say “unknown”. The dev put out a 2.7 update to fix some issues created by newer versions of HA. I took that too without luck. Ive made the necessary changes in my config.yaml for the new rekognition “targets”, but still no dice.

The only error im seeing in my HA logs is:

  • Logger: homeassistant.helpers.service
  • Source: helpers/
  • First occurred: 8:46:47 AM (4 occurrences)
  • “Unable to find referenced entities image_processing.rekognition_person_fy1”

I have never been able to install rekognition manually, but the HACS method has worked great for months until now. Anybody else having this “unknown” state with their rekognition entities or have an idea on how to solve this? Thanks.

1 Like