Problems with installing Whisper

I installed Whisper and Piper add-ons and tried setting them up. I started the add-ons and continued to the devices and services tab in the settings. I can see piper and I clicked configure but when I tried to configure Whisper there was no option to do so. I can’t see Whisper there.
I have to note that I had problems starting Whisper the logs would say Service exited with code 256 (by signal 4). It does sometimes crash.
Could anyone help me with it?

I have the same problem with the same errors. Did you happen to come across a fix?

Unfortunately I didn’t find a fix. I just gave up

Not sure if this is the same issue, but I ran into something similar with both Whisper and Piper.

After installing the Addons, both were not automatically discovered on the integration page, but they were listed in the device tab. I manually enabled the Sensors for both Devices, but still did not show up in the Voice assistant setup page.

I ended up Manually adding the Integration, using the + Add Integration Button, searching for Whisper/Piper, and Giving it the host connection info.

You can manually set the ports, in the Config of each of these items if you are not sure what port they are using.

I used:
whisper: Host: Port: 10300
piper: Host: Port: 10200

After I did this, I was able to Select them in the Voice Assistant Setup.

I did run into Hard drive space issues when I was working though this setup, I had ended up extending my Storage in My HyperV VM, not sure if that was at all realated, I guessing not, but fugued I’d mention it.