Problems with multiple-entity-row

Hello,
I have some serious problems in getting multiple-entity-row to work.
I have spent quite some time and are stuck - I hope someone can help.
I am on 0.116.2
As per : this link I created this www directory:

/usr/share/hassio/homeassistant/www/

Copied the script to the www directory : https://raw.githubusercontent.com/benct/lovelace-multiple-entity-row/master/multiple-entity-row.js
with wget

added this to configuration.yaml

lovelace:
resources:
- url: /local/multiple-entity-row.js?v=3.4.0
type: module:

Everything as written in the readme.

In the lovelace editor I added:

  - title: test2
    path: test2
    badges: []
    cards:
      - type: entities
        entities:
          - entity: sensor.vaxthus_mean_temp
            type: 'custom:multiple-entity-row'
            name: temp
            secondary_info: last-changed
            entities:
              - sensor.vaxthus_temp_max

lovelace2
What am I doing wrong here, I cannot find my misstake so I hope someone can help.
Thanks in advance.

I think you need to remove the single quotes in the type: line.

What does this mean exactly?

Do you have a file in your www folder called “multiple-entity-row.js” right now?

Also make sure that the configuration.yaml code is formatted correctly. If that’s really the way it is in the yaml then that isn’t correct.

Did you restart HA after you made all of those changes?

BTW, the single quotes are fine.

1 Like

Yes - I have the “multiple-entity-row.js” file in the /homeassistant/www/ directory

I post a picture on the configuration to get it right…
config

Is the reason that HA cannot find the .js file in the www directory?
If i browse to:

https://mywebsite.com:8123/local/multiple-entity-row.js
I can see the script in the browser so it´s there

Can I in any way trace or check logfiles to find the error?
I ave been stuck for quite some time…
Thanks for support!

Are you using yaml mode for lovelace or are you configuring it thru the GUI?

I have tried both. I made some entities in the GUI and then edited in in the yaml editor.
I cant figure this out…

I guess what I’m asking is - right now, do you have:

lovelace:
  mode: yaml

in your configuration.yaml?

If not then you need to add the resources to the lovelace dashboards section of the configuration menu from the left-hand menu.

Oh, I get you.
No - i did not have that, added it but same result…
Perhaps I try to update to latest version of HA… but i rarely think it would help…
Cantunderstand why it says that the Custom element does not exist, must be that the .js are not read for some reason… complete mystery…
again thanks for tips! appreciated.

OK, before we go further let’s iron this out.

Up till now, since you didn’t have that in your config, I assume you have been editing your lovelace views via the GUI? Is that correct?

Yes that is correct.
I have edited the lovelace GUI with the “Edit Dashboard”, I have a simple set-up with just some light and switches.
Thanks for taking the time!
I am in the EU time zone…

Hello,
I managed to get it working.
I made a simple mistake in creating the www directory under /homeassistant/ so I moved this to /hassio/www and it works as expected.

Is it correct thath this feature (multiple-entity-row) only works in yaml mode of lovelace?
When I edited the ui-lovelace.yaml it worked. Then I pasted this in to the raw format in lovelace after removing the yaml mode in configuration but then it failed… so I guess I have to stay in yaml mode, right?
Thanks a lot for help and input - really appreciated :slight_smile:

That shouldn’t be right. the www folder should be created under the /homeassistant/ folder where you had it.

That’s where mine is right now and I’m using custom cards as well.

No, it should work in whichever mode you configure lovelace. You just have to make sure that the resources are in the right place and referenced in the right location. you put the resources in the configuration->lovelace dashboards page under the “resources” tab if you are configuring your lovelace in non-yaml mode and in yaml mode the resources go in the configuration.yaml file under the lovelace: heading.

What “this” are you talking about?

The resources or the card config or something else entirely?

also unless you put my username in your post (starting with @) or you click the reply button on one of my posts I don’t get a notification that you replied to me so I don’t know to check the thread again.

1 Like

Hello and may thanks for the help - I now think I got it right but lovelace is not very straight forward… for me…

Before it did not work without having this (bad) config

/hassio/www/multiple-entity-row.js
yaml mode

However after a server reboot it failed again and moving to:

/homeassistane/www/multiple-entity-row.js
# yaml mode

Defining the resources in Configuration->lovelace solved the UI config mode when learned about the HA Advanced mode - another 30 minutes life spent :slight_smile:

“This” referred to the yaml config I had for the multiline feature in ui-lovelace.yaml - I tried to copy this to raw editor to get out of yaml mode but at this time I did not have the resources properly defined.
Again thanks!

Now it works but still the GUI editing of the card - is this expected?

I think so but I’m not completely sure because I never use the GUI for any configuration unless I have to (not for lovelace, automations or scripts but I have to for some integrations). I just prefer yaml.