Problems with proper addon names while using the "Create Partial Backup" service

So here is the thing, I’m trying to automate backup’s, but I need it to be a partial one, I’m not interested in the contents of media folder, so I tried to configure the “Create Partial Backup” service with some success. I can call the service with most addons and it works, but I have the crowdsec-firewall-bouncer and the uptime-kuma and so far I can’t get those name slugs correctly. I understand that the name slug is the part of the name that’s after de “addon_” if you go to portainer and look for the containers names according to some other entries in the forum. So the names for those 2 are supposedly: 424ccef4_crowdsec-firewall-bouncer and a0d7b954_uptime-kuma, but if I try to use those names I an error that says to change it to this “424ccef4_crowdsec_firewall_bouncer” and try again… If I do that, I don’t get the error but I also get an empty backup…

The only thing I can think of is that these addons have a composed name with the “-” in the name, different from the rest of the addons that work. Does anyone have an idea of what is happening or what I need to change to make it work.

Is the part from the browser path identical? For example, the Samba addon’s path is …:8123/hassio/addon/core_samba/, so slug is core_samba.

yeah it is, for the uptime kuma is (…:8123/hassio/addon/a0d7b954_uptime-kuma/info)… and the crowdsec firewall bouncer is …:8123/hassio/addon/424ccef4_crowdsec-firewall-bouncer/info

So I’m now certain that the slug name that I using is correct and there is something else to this issue. I tried the restart addon service and configured a restart for the crowdsec-firewall-bouncer addon as you can see here:
then I changed to the yaml editor and got this:
as you can see the slug name is correct as I have it. Most important this runs properly.

But if I use that slug name as parameter for the create partial backup service like this

It fails and recommends to change the slug name, but that doesn’t work as well as I already mentioned.

any ideas??

Alas, no. The only thing I can suggest is to taise an issue.

Same for me
The file name is slug name and not backup name.
Partial and Complete backup, manual or auto backup…
My storage is an NFS one…
I try to switch on local drive. The same…