Problems with RPi recognizing z-wave stick

I had a system failure with my raspberry pi a couple of days ago. During the boot process I would get a kernel panic message and the system would halt. I was able to get the sd card mounted under a different linux system and recover all the files. I reformatted the sd card, then moved all the files back. My pi can reboot like normal and home assistant is coming up fine except when I install my Aeotech Z-stick there isn’t a /dev/ttyACM0 in the /dev folder. When I run lsusb, the device is listed and I don’t see any error messages in dmesg or /dev/var/syslog. I’m guessing when I copied over the the original files, I copied over something that is preventing /dev/ttyACM0 from loading properly but I don’t know what that is. Any ideas?


It may well not be ACM0, the simplest way to find out what the device is would to unplug it, reconnect it and then run:

dmesg|tail -n 50

In there (most likely in the last half dozen lines) you should find the details of the stick.

Oh sorry, forgot to include that detail. I had tried doing that and unplugging and replugging in the device gives me these messages for dmesg:

[155761.748461] usb 1-1.4: USB disconnect, device number 4
[155764.156420] usb 1-1.4: new full-speed USB device number 5 using dwc_otg
[155764.259668] usb 1-1.4: New USB device found, idVendor=0658, idProduct=0200
[155764.259689] usb 1-1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0

That is the right idVendor and idProduct. Maybe Mfr, Product, and SerialNumber are strange but I don’t know since I don’t know what they originally were.

Ok, what does ls -al /dev/tty* show?

/dev/tty    /dev/tty12  /dev/tty17  /dev/tty21  /dev/tty26  /dev/tty30  /dev/tty35  /dev/tty4   /dev/tty44  /dev/tty49  /dev/tty53  /dev/tty58  /dev/tty62  /dev/ttyAMA0
/dev/tty0   /dev/tty13  /dev/tty18  /dev/tty22  /dev/tty27  /dev/tty31  /dev/tty36  /dev/tty40  /dev/tty45  /dev/tty5   /dev/tty54  /dev/tty59  /dev/tty63  /dev/ttyprintk
/dev/tty1   /dev/tty14  /dev/tty19  /dev/tty23  /dev/tty28  /dev/tty32  /dev/tty37  /dev/tty41  /dev/tty46  /dev/tty50  /dev/tty55  /dev/tty6   /dev/tty7
/dev/tty10  /dev/tty15  /dev/tty2   /dev/tty24  /dev/tty29  /dev/tty33  /dev/tty38  /dev/tty42  /dev/tty47  /dev/tty51  /dev/tty56  /dev/tty60  /dev/tty8
/dev/tty11  /dev/tty16  /dev/tty20  /dev/tty25  /dev/tty3   /dev/tty34  /dev/tty39  /dev/tty43  /dev/tty48  /dev/tty52  /dev/tty57  /dev/tty61  /dev/tty9

/dev/ttyAMA0 looked interesting but I don’t think that is what I’m looking for. That one is linked to serial1. /dev/ttyACM0 was the device I had before I reinstalled so I keep expecting to find that.

Easy check to see if it’s AMA0 - disconnect the stick and see what vanishes from there.