Problems with sonoff sensor

I’m having trouble pairing with a Sonoff SNZB-02P sensor. I paired 6 of them, 5 work well and only 1 is detected but does not update temperature and humidity. In your opinion, why?
I’ve already returned it once, got 6 new ones and the same thing happens again.
I have home assistant latest release and Sonoff Zigbee USB dongle.

I tried deleting the sensor and doing a new pairing, then reconfiguring it but it doesn’t change the situation

Thank you so much!

After deleting the sensor you need to restart Z2M (if using Z2M) before doing the new pairing.

Start by updating firmware on Zigbee Coordinator and take actions to follow best practices before troubleshooting any deeper → Zigbee networks: how to guide for avoiding interference + optimizing using Zigbee Router devices (repeaters/extenders) to get best possible range and coverage

I’ll try in theese days but the sensor is connected but send data only one time when I reboot home assistant and never more , the others 5 bought the same time works well. Do you think it could be the firmware?

What else have you in your Zigbee network? How many sensors and how many mains-powered devices?

1 sonoff dongle with z-stack 3.x.0
6 sensors snzb-02p

All sensor installed in the same time, 1 doesn’t work and is far 2 meters from dongles with no walls in the middle

If you move a working sensor to the location of the failed sensor, does it fail too?

I have a dead spot in my house that disables almost any device moved to that spot. Doesn’t matter if I have a router nearby either.

No mains-powered devices at all? That’s not how Zigbee works - it’s not wi-fi.

Zigbee sensors send messages to the dongle through a mesh of mains-powered devices (routers). They can connect directly, but there is a limit to the number of devices the dongle can link to and connections will always be vulnerable to environmental factors like interference.

Zigbee works best where every light and every socket in the building is a router, giving the signals many different routes to follow. Distance is only one of many factors to consider.

How many routers you need will depend on the layout and structure of your home, but if it’s any help. I have three or four routers in every room - nine in one room.


Yeah it still sounds like you doing the opposite from following these best practices tips:

Those type of symptoms are common indicators of EMI/RMI/EMF-interference and/or poor reception.

The first thing you need to know is that all Zigbee radios can be extremely sensitive to EMI/RMI/EMF-interference, and the second thing you need to know is that a Zigbee network’s range/coverage depends heavily on mesh networking by design because Zigbee radios use low-power and high-frequency radios have very week signals with poor propegation (crappy penetration of building materials). Those two combined can create the perfect storm, so you really need to take preventive actions to both avoid placing Zigbee devices too close to sources of EMI/RMI/EMI. Read and follow these best practices:

The most important preventive actions to take in order to avoid the first is to connect the Zigbee Coordinator USB radio dongle via a long shielded USB extension cable to a USB 2.0 port of USB 2.0 hub and keep it away from USB 3.0 devices/peripherals/cables, and to prevent the second you want to begin by also add many always-on/always-connected/always-powered mains-powered Zigbee devices at strategic locations in your home that act as “Zigbee Router” devices (sometimes also referred to as Zigbee Range Extenders or Zigbee Repeaters) before adding any Zigbee End Devices (which include all battery-operated devices as we.ll as a few mains-powered devices too, which is especially common if they do not need neutral or if they are a lightbulb)

Other than that you as well need to replace batteries with fresh ones in any battery-operated devices.

Again, read and try to follow this → * Zigbee networks: how to guide for avoiding interference + optimizing using Zigbee Router devices (repeaters/extenders) to get best possible range and coverage

After followed all that advice then try re-pair the device again before doing any deeper troubleshooting.

Also suggest try upgrade to the latest unofficial community Zigbee (NCP) firmware build on your Zigbee Coordinator radio adapter, nothing that if you have a Sonoff Zigbee from ITead then remember that there are two different Sonoff Zigbee 3.0 USB Dongle Plus models (“ZBDongle-E” based on Silicon Labs EFR32MG21 radio SoC and “ZBDongle-P” based on Texas Instruments CC2652P radio SoC) that uses different firmware builds.


Forgot to mention that another option is to switch to a different Zigbee channel with less noise/usage, but that should preferably only be done after first already tried to switch your Wi-Fi channel (if possible). See:

Surley not impossible if you add more Zigbee Router devices, but yes due to the being Low-Power radios using Ultra High Frequency signals it makes them extremely sensitive to EMI/RMI/EMF-interference if the source is too close as well as giving them relatively bad radio propagation which translates into poor penetration of building material, so there can be some areas that are very hard to get good coverage. The key is to both avoid having sources of EMI/RMI/EMF-interference to close to Zigbee devices (especially the Zigbee Coordinator) and adding loads of Zigbee Router devices, or else it can sometimes feel similar to an illumination problem (penrose unilluminable room scenario) where you are simply not getting full coverage relying on using basic Line-Of-Sight (LOS) propagation, at least until you added even more Zigbee Router devices that acts as repeaters in the Zigbee network mesh.

Nope, some sensors doesn’t work. At first there were 2 sensor that are failing, now i uninstalled the dongle (plugged in raspberry with HA), and now are 2 different sensor thar doesn’t work

the sensors are distand maximum 2-3 meters from the dongle (i have a small house), it’s strange that the sensor more distant (5 meters) and with a wall between the dongle works well. i’ll try to put more routers (lamps, and sockets)

WOW thank you so much for your help.
A last question, how is possible that a sensor communicate correctly every 3 minutes the humidity and never the tempererature? that’s strange, probably is broken 'coz if the connection is bad, it doesn’t communicate anything

If it is a battery-operated sensor that they usually only send updates on state change, so if the temperature does not change then it should not send updates, but if the humidy does change then it will send an update about that. All battery-powered devices do that to save power. This of course depends on how the manufacturer configured the firmware to work various brands and models or even firmware versions will work differently.