Problems with Z-Wave JS integration and Razberry Board


I am trying to setup a new HA installation and am a little bit frustrated…

My Setup:
Raspberry Pi 3B+
Razberry Z-Wave Board attached to GPIO
Home Assistant OS 5.12

The hardware is ok because it all worked with an old installation with Open Z-Wave and also with Z-Way software.

What I did:

  1. Unbind all Z-Wave devices from the board and upgrade firmware and reset board with Z-Way software.
  2. Flash SD-Card with latest HA OS 5.12
  3. Do basic configuration (location etc.)
  4. Install and start Z-Wave JS Supervisor addon and configuration (Device /dev/ttyAMA0 and network key). The addon seems to be running ok
  5. Then the problems began: Next I wanted to install Z-Wave JS integration but it always says “connection failed” no matter if I try with ws://localhost:3000 or ws://[IP of the Raspberry Pi]:3000.

This is so frustrating, because I really like HA. Can you help me please?

Thanks a lot! :slight_smile:

See if this thread is of any help to you:

Hi Rick,

thank you for your reply. Unfortunately it doesn’t really help :frowning:
The solution says to choose another device in the dropdown menu but I have only /dev/ttyAMA0 to choose. And I don’t use Zwavejs2mqtt.


The host name for the connection would be core-zwave-js
So ws://core-zwave-js:3000

Also make sure you don’t have any other configurations or addons accessing the Z-Wave module

With this settings the problem still exists :frowning:


After confirming HA changed to localhost and “no connection”:

In the meantime I tried OpenHAB with another SD-Card. Here I could connect to the GPIO board without any problems (device /dev/ttyAMA0). What I had to do here was do some configuration of the GPIO port so that it is not blocked by bluetooth or whatever. Maybe this also has to be done here at Home Assistant? But how.

How can I check what blocks the Z-Wave module? I made a clean install of HA and only the Z-Wave JS Supervisor addon is installed. No other addons.


Maybe this thread is of relevance to you?

Thank you very, very much, this is the solution! :slight_smile:

It was my mistake, it would have been described here :relieved:

1 Like