Proxmox install failing

So I bought an old Lenovo Thinkcenter tiny (M92 i5 3570t, 16g 64g ssd)
Been trying to work out the best way for a somewhat n00b to install HA (Currently on pi3)
docker didn’t allow HomeAssistant easy with the now on hold depreciation , Core was a pain as I rely on add on’s

Tried whiskerz007 proxmox script twice and it just wouldn’t boot, hung the VM proxmox couldn’t control the VM well
The moral of this post, KVM Hardware virtualization setting in proxmox is important! It was the root of my proxmox failures.

Why did I turn it off? The setting in my bios was off, and proxmox didn’t like that unless I turned it off in proxmox.

Why make this post? Didn’t see any info about it anywhere and the more community stories the more support n00bs can get.

Thanks HA community

Hi,

This might be an incompleet proxmox install.
You mention you have 1 thinkcenter with 64gb. If this is the only disk in there your using, than you havent installed proxmox as should yet. Proxmox doesnt allow to install VM’s on the OS-storage. It needs atleast 1 extra disk, preferrably 2.
This guy, Jeff as always, gave me a good start installing proxmox https://www.youtube.com/watch?v=azORbxrItOo

The whiskerz script is not aware of any proxmox issues, so it just tries to do what is in the script.

I have been using proxmox for years on a NUC with only one disk… And it just works.

GV

1 Like

Multiple partitions though,

:slight_smile: ok, wasnt aware of that. The info I read told me otherwise. But if it works, it works right.

Maybe Bryden could give a little bit more info on this himself. How he arranged his rig.

At OS level you mean?
Not even, here is the partitioning of my disk:

Disk /dev/sda: 447.1 GiB, 480103981056 bytes, 937703088 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: F5D86CE1-98A2-4C87-9D7A-C76A4A1CE1D9

Device      Start       End   Sectors  Size Type
/dev/sda1      34      2047      2014 1007K BIOS boot
/dev/sda2    2048    262143    260096  127M EFI System
/dev/sda3  262144 937703054 937440911  447G Linux filesystem

Then proxmox does its “magic” and creates volumes there.

GV

1 Like

@greengolfer. How do you download containers or upload VM’s then?

Anyway. The size of the Bryden’s disk, 64gb, think that might be too little? yours is 450gb.
Otherwise, I cant help. Maybe you guys have a theorie

Within proxmox, I created two volumes. One for the templates and the other one for the VMs and container.

At the time, I just followed blindly proxmox documentation https://pve.proxmox.com/wiki/Installation

64Gb should be enough. I would keep 48Gb for data and split the rest for root, swap,…

GV

Drzzz’s has a pretty good video on installing Proxmox and setting up HA. It’s worth looking at.

Just did a quick search, and he has three up there, I guess that’s my morning viewing sorted!

One question I haven’t found a good answer for relates to other docker containers. I have about 6 other containers running with docker-compose alongside my HA Supervised installation on Ubuntu server 18.04. What do I do with them if I move to Proxmox? Setting up a separate VM with Ubuntu under Proxmox to run Docker seems to me to be adding unnecessary layers of virtualisation and just feels wrong to me.
Suggestions?

Yeah. Set up another VM… or better still stick with your HA Supervised solution. It has been flagged by a mod a few times now that going forward Debian + HA Supervised is likely to be supported.

Hmm, “likley” - that doesn’t give me a warm cosy feeling! I’m so far down the road with Home Assistant that there is no turning back, so I need a platform that will continue to be supported well into the future. Apart from regular updates, I rarely touch my system - if it ain’t broke, don’t fix it.
As it turns out, I have a few Lenovo M92 tiny devices sitting around so I’m going to try Proxmox on one of those. @Bryden Do you know that you can upgrade the CPU in the M92 to an Intel Xeon for extra cores? I got one for €50 on Ebay and it works great - no overheating issues. Just make sure you upgrade the BIOS first to ensure support.

Yeh running a single old OCZ vertex ssd in the machine 64g, no partitions, proxmox does set up volumes in the installation.
I seem to have ethernet issues on mine (most likely user issues).
HA install seems to be running fine, tried spinning up other VM’s failing totally, Like SOTA mentioned, I wanted to run ubuntu server with docker and portainer to throw some other things up.
HA does need to support a general nix machine, they are so cheap with a ton more power than a pi.

Sota, CPU upgrades, not many, you need to watch the TDP of the chip, cooler is only really good for 40w at a guess, the i5 3570t is 35w, there is a 3770t i7 upgrade and a zeon chip you may be able to use, the zeon’s are way cheaper than an i7, an i7 alone costs what I paid for the machine. ($120aud + 70 for 16g ram upgrade, the ssd I had sitting in a draw)

Just to share my experience and get some new…

Started with HA a few months ago and and a few months before that, discovered Proxmox, which I run on a i3/4c/16GB.
So instead of installing a full VM for HA I installed in a container because I have multiple isolated services in several containers.
Therefore, to minimize the footprint, I chose to use a container which seems to be more then enough - until this point at least.

Since HA runs on RPi’s, do you really need a full VM for it?

I assume you are taking about LXC container that are available on proxmox.
According to some documentation page (can’t find the link right now), this method is not recommended for HA.
Therefore on proxmox that gives you many options all VM based:

  • Hassos (using whiskerz script for example - https://github.com/whiskerz007/proxmox_hassos_install)

  • Any linux OS (eg debian) and then Home Assistant Supervised (generic linux install). This one that may or may not be supported in the future

  • Any linux OS (eg debian) with Docker and then Home Assistant Core as a docker container + additional docker container if you want too.

I have tried them all. It really depend on what you prefer.

GV

PS: Not taking about the venv that I have never tried (and don’t really understand either…)

Yes greengolfer, LXC containers.
This seemed to be the obvious way in my limited experience with both.

Yep, I installed in that virtual environment, don’t understand really all the different options TBH… :blush:

But as I wrote earlier: I’m really surprised how low the load is with 7 LXC containers and 1 Win-VM on this machine.

Well, if as you say, you have limited experience, then the “main” road on proxmox would be using VM with hassos (so the 1st of three options above). Not sure what are the drawbacks of what you’ve chosen. It will work until it won’t :slight_smile: And then, you are on your own in this situation!

GV

Sorry, Im still rocked about this… :rofl:
I have been bashing my head against the monitor for a couple of nights to get it working… :face_with_hand_over_mouth:

edit > add reason a bit. Not that this helps Bryden in any way. But it might scare people off if I leave it like that.

Proxmox is great and easy to work with. Just the hassle I had, made me forget how easy it can be.
Situation for me was slighly different. I came from HomeAssistant running in VirtualBox. I needed to convert that virtualbox image (raw) to qcow2 image. 32Gb image size got 48Gb as the qcow2 image. Then upload it to Proxmox.

Uploading an image larger than the proxmox local disksize is not a simple task, as during the upload it stores the file in a local temp directory or something. Eventhough the disk I was uploading it to, was 250Gb. at 25-ish Gb it would just stop uploading. A bit of a kick to the head this was.
In normal situations, uploaded iso’s do not make it >2Gb often. ghehehe…

I fixed this by putting this qcow image directly on an USB hdd first, and mounted it as directory.
End of the story is that I did manage to import an VirtualBox image into Proxmox and get it running propperly, including usb passthrough etc.

Long story… probably useless :slight_smile:

You were looking for trouble :wink: and you found it :grinning:
Instead of transferring the VM you could have saved the HA config (aka snapshot), create an empty VM (with the “right” size), run the install script and import the snapshot.
Probably easier to do.

GV

Yeah, I tried that first. got a lot of error messages. Unstable hass.io at that time. Dont know why. Maybe they could have been solved, But I chose the learning curve like a cliff. :slight_smile: Gheheh