Proxmox, NUC and Bluetooth - again (sorry!)

I decided to revisit the old Proxmox, NUC, Bluetooth issue.

I’ve done some research and it seems that many people are getting it working but I can’t work out if the steps are within my grasp (I know only the basics of Linux and am not a Proxmox expert by any means).

As with many of these things the advice/solutions seems to change with time.

But I have seen this on Reddit:

You should see USB 1.x device with no name listed, this is the bluetooth card. You can pass this through to the VM without passing through the PCI wifi device.

And this:
HA Github (closed) issue

Both from about Oct 2021.

So, if I try to add a USB device to my HA VM I have two options:


Am I on the right track? Will one of these make Bluetooth available to HA (If so which one)?

I know this is an old question but it seems to me that the NUC/Proxmox/HA setup is now quite popular so maybe there is a ‘simple’ solution now that I have missed.



@klogg indeed adding and normally should work. Recently no longer working here with same setup. So trying to understand what I’m missing.

Did you manage to get it working?

Currently reading this

I never actually tried yet. I have a reason to want Bluetooth on a VM but it is just not pressing enough for me to have got round to it.

Any update here?


Can confirm!

In proxmox I went to the Homeassistant VM > hardware > add > USB Device > Use USB Vendor/device

Then selected the usb 1.x that had no name and after a reboot I was able to see the bluetooth integration as well as it found ibreacon tracker. However… getting my govee led strips to work may be a bit more difficult than clicking through next menus :frowning:


Fixed the problem for me too! Thanks for posting.

Thanks! It worked also for me!