Proxmox running Hassio + Plex able to access media on NFS share

So I’m not the most savvy when it comes to Linux, but I’ve finally managed to get this working. I’ve got one instance of Debian running in Proxmox running both homeassistant and plex in docker with plex being able to access my NFS share on my Synology NAS (but was even able to get the hassio plex add-on to be able to access the NFS share also.

I bought a NUC ages ago to upgrade from a raspberry pie for HA. To get this setup I used the whiskerz007 script, which was featured on DrZzz’s YouTube channel. This was great, simple and straight forward, but when I tried to use the plex add-on, I couldn’t get it to see the NFS share with my media which is on my Synology NAS.

My HA instance broke for some reason after a power outage recently, so I had to set it all up again (but fortunately from a recent backup).

What I did this time was still using Proxmox, I used a different Whiskerz007 script to create a LVM running home-assistant ( This setup an LXC container running Debian with homeassistant installed running in docker. I installed portainer and could see them working away. This guy does a great tutorial on how to install portainer ( but it’s basically two lines in command line available on portainers site (

From here I could have gone one of two ways. I could either use the plex add-on OR run plex in docker without involving home-assistant. I decided to do the latter, meaning if my HA is down for some reason, or needs a restart for a config change, it won’t affect plex.

With regards to my NFS share, I was able to get Proxmox to see this and add it as a volume in Proxmox). Then I edited the LVM config file (as per this YouTube video: - essentially the added line was mp0: SOURCE, mp=TARGET or in my case mp0: /mnt/pve/video,mp=/usr/share/hassio/media/). I chose to map it to /usr/share/hassio/media incase I did want to use the plex add-on, as this is where it looks for Movies/TV. Worked perfectly in the plex add-on when I tried it.

When I setup plex directly in docker to see if it worked this way (and this is the method I kept), I just had to bind the /tv and /movies volumes to /usr/share/hassio/media/movies and /usr/share/hassio/media/tv shows and then plex was able to easily find them on initial server setup. I used the official plex docker container but the /tv and /movies binding instructions are actually from the linuxserver plex docker container (

I realise I probably haven’t written the above very clearly, but hopefully it makes sense to someone else and is helpful! Basically by just watching those videos I went from knowing nothing to being able to set this up and get it working.

1 Like

I was looking for something like this, but i’m not able to find this path on my Prox Server “/usr/share/hassio/media/” this path was working great on my ubuntu installation… any idea how to access to the HA folder from Prox??