Proxmox VM - unable to update HassOS from 4.12

Tags: #<Tag:0x00007f3266982458> #<Tag:0x00007f32669822a0>

Hello,

I’m running a Proxmox VM (deployed a while ago with the whiskerz script) and it won’t update. It waits for exactly an hour than fails:


21-01-27 14:26:35 INFO (MainThread) [supervisor.hassos] Fetch OTA update from https://github.com/home-assistant/operating-system/releases/download/5.10/hassos_ova-5.10.raucb
21-01-27 15:26:35 WARNING (MainThread) [supervisor.hassos] Can't fetch versions from https://github.com/home-assistant/operating-system/releases/download/5.10/hassos_ova-5.10.raucb: 
21-01-27 15:26:35 ERROR (MainThread) [asyncio] Task exception was never retrieved
future: <Task finished name='Task-103224' coro=<process_lock.<locals>.wrap_api() done, defined at /usr/src/supervisor/supervisor/utils/__init__.py:24> exception=HassOSUpdateError()>
Traceback (most recent call last):
  File "/usr/src/supervisor/supervisor/utils/__init__.py", line 33, in wrap_api
    return await method(api, *args, **kwargs)
  File "/usr/src/supervisor/supervisor/hassos.py", line 149, in update
    int_ota = await self._download_raucb(version)
  File "/usr/src/supervisor/supervisor/hassos.py", line 97, in _download_raucb
    raise HassOSUpdateError()
supervisor.exceptions.HassOSUpdateError

Trying to update from the CLI results in the same error log.
The Core updates successfully from the GUI.

I searched extensively for this problem but only found suggestions for updating through USB boot, nothing about VMs.

I tried downloading the .raucb file using wget inside the VM and it downloads fine, although it stalls multiple times and I have to restart.

Is there a way to executing the update file from the CLI?
Is there anything I’m missing?

The NIC is DHCP with a reservation on the DHCP server.

Thanks in advance