PSA: 2024.7 Home radius in General settings or zone settings

In 2024.7, you can now edit your home radius via the UI.

To access this ability, your general settings must be fully controlled by the UI. This means you cannot have the following keys in your configuration.yaml file’s homeassistant section:

  • name
  • time_zone
  • elevation
  • currency
  • country
  • latitude
  • longitude
  • language
  • internal_url
  • external_url

To enable UI management, remove the above keys from the homeassistant section and restart home assistant.

Here’s an example confing that contains the keys:

homeassitant:
  name: ...
  time_zone:  ...
  elevation: ...
  currency: ...
  country: ...
  latitude: ...
  longitude: ...
  language: ...
  internal_url: ...
  external_url: ...

All of these keys can be managed by the UI, make sure to take a screenshot (or copy the information) so that you can add it via the UI.

EDIT:

You also need to remove

zone.home:
  radius: ...

from your homeasisstant customize section (customize.yaml).

9 Likes

Thank you.

Or if you had previously edited the Home radius via a Zone override for Home, that needs to be removed.

I had a zone overide working.

So I’ve removed the customize.yaml file and also the reference to it in the configuration.yaml file as follows - including deleting the “homeassistant:” line

homeassistant:
  customize: !include customize.yaml

Have rebooted but still get the message I can’t edit radius in the UI. Would be grateful for tips on troubleshooting

It won’t be in customize, it’ll be in a zone.yaml file or zone config in your configuration.yaml

eg:
configuration.yaml
zone: !include zones.yaml

zones.yaml

- name: Home
  latitude: -31.xxx
  longitude: 115.xxxx
  radius: 30
  icon: mdi:home

Thanks… but I have no zone.yaml (or zones.yaml) or zone/s config in configuration.yaml.

I set it up with a customise.yaml file as per my initial email. I have another HA instance still set up like that and with the zone working well.

It’s no big problem… can easily redo the customize.yaml file

Well, it seems odd that if you excluded that file that HA still followed those settings. Did you clear the browser cache?

1 Like

rookie error… all fixed now… wish I could buy you a coffee!

1 Like