PSA Controller Car - Addon set up / OTP Config

Hello,

I have installed the PSA Car Controller as per … psacc-ha/psacc-ha at main · flobz/psacc-ha · GitHub
After the addon is stated an “OPEN WEB UI” button is displayed
=> but there is nothing about this Web UI in the add-on page .

Opening the WEB UI shows a configuration page as per the attached screenshot .
=> but which credentials are required , from which PSA account ? there is nothing about this in the add-on page .

My car is an Opel one;
Thank you for advice .

I opened the WEB UI + the “User Config” tab and filled the required parameters :

  • Car brand : Opel
  • Email & Password : Same as “My Opel” Android App

After hitting “Submit” a message was displayed : “Success , Go to OTP Config tab” and then Click to send SMS.

=> After clickjing to send SMS , No SMS received
=> From where my phone number is known by the add-on ?
=> same for PIN Code

Thank you for clarification

I have uninstalled and re-installed again the PsaCc add-on for a new configuration and … same behavior :

  • User config OK
  • OTP Config : SMS sent but no code received by SMS

=> Is it a known issue ?

Thank you

=> From where my phone number is known by the add-on ?
=> same for PIN Code

You have to have the e-Remote connected service active and registered in your app and in your vehicle. When you go through the activation steps of this service, you have to register your phone number and set a pin-code. My guess is that the add-on uses the same API for registration as the process is exactly the same.

Use the same pin-code you set in your app to use with the psacc addon. When everything is up and running, just go through the steps (login → OTP config) and you should be set.

I’ve been trying to get this set up for a couple of days now, as obviously the MyPeugeot app is a nightmare and here in New Zealand we aren’t eligible to activate the remote management service via the app anyway, but after reading about the PSA Car Controller I thought I’d found a great workaround.
However, after learning how to get a VM setup, installing HA and the PSA Controller car add-on, I’ve gotten stuck on the SMS OTP as it just says “SMS sent” but I never receive it. Now reading this thread, I’m thinking the fact that we can’t get e-remote here means I’m not going to be able to use this either. Please, someone give me some good news! :slight_smile:

Edited to add:
Ok, so I’ve found and faq on github, so thought I’d add it here in case anyone else finds this thread before they find the FAQ as I did.

" 5. I don’t receive SMS

The SMS authentication is used to be able to remote control your car. If your car doesn’t have this functionality you should disable remote control when you start psa-car-controller by using --remote-disable argument."

Now I just need to work out how to actually do what this step is telling me to do…

As far as I can tell, this is where I should be adding the “–remote-disable”:

However, I still get prompted for the SMS which never arrives, however the web UI does eventually update to show:

Now, fair warning, I am a complete beginner at HA, Python, etc. and (probably incorrectly I’m realising now) thought that once I got HA up and running, installing the PSA Car Controller add-on would be like installing an application on my laptop or app on my phone ie. enter the MyPeugeot login credentials and it would work.

Following the info here: GitHub - Flodu31/HomeAssistant-PeugeotIntegration: Integration between Peugeot API and Home Assistant
I’ve updated the sensor & configuration script, changing the “IPofTheSoftware” to that of my HA, and the “YourVIN” to the VIN of my car throughout the code, but I still don’t seem to be getting anywhere.

Any help anyone can offer would be greatly appreciated.

I have the same problem. I run addon with

PSACC_OPTIONS: "-r --web-conf -c --remote-disable"

but I still can’t get any vehicle info. I check out car model yaml file and saw that this file doesn’t have my car model and VIN listed. I proposed changing this yaml file, but for now there is no change.
I believe that problem might be in a fact that my VIN number and car model is not listed in this file, but I’m not sure.

Thanks.
Should that car model yaml appear in the Config list as part of the installation od PSA Car Controller add-on, or do I need to create it?

I’ve tried the install several times now, once I’ve found the sensor.yaml to update but after my latest install it’s not showing. Everything I do seems to be one step forwards 2 steps back :smiley:

I have now worked out it wasn’t as simple as setting up HA and installing the PSA add-on, but I also needed to install lovelace, samba share, SSH, HACS, and edit the conguration.yaml and sensor.yaml (obviously hard to do if it’s missing…). For the latter, can I just create a yaml file of that name then add the neccessary code?

So many questions :slight_smile:

I don’t know to all of your questions. I installed this addon and nothing was working so I was checking the doc. I just proposed changing this car model yml file but nothing happend so far.
It will be nice if some of developers clear this situation out because its obvious that many people have problems settings this addon.
And still this addon doesnt work.

Thanks.
Interesting, I don’t seem to have a car model yaml file. Was that auto created for you?
I didn’t have a sensor.yaml either, so created that myself.

As I know no it was not. I didn’t edit file locally as this is somewhere in docker image. It’s possible to do it but I forgot how. I know that settings wasn’t saved after editing config in docker.
But we as end users shouldn’t do that. Developer should change that file so that we can download new image