Public DuckDNS domain is not loading

I installed DuckDNS following the official guide and tried to set up SSL with Let’s Encrypt
But when I open my DuckDNS URL in a browser the page doesn’t load (err_connection_timed_out)


Eero config:

No error in the logs:

SSL certificate is invalid?

did you set up the nginix integration?

Yes, no error showing in the logs


nginx config

I followed the guide here:

After I enabled nginx, I can’t access local HA with https, I get this error:
Before installing nginx, I was able to load the page with https, but the SSL lock icon was broken

Could be a problem with eero routers?

can you access home assistant from outside your lan?

under the yaml how did you set up the port forwarding? do the ports follow your routers port forwarding?


Container Host Description
443/tcp 8444
80/tcp 80

I used to be able to access duckdns public URL outside my network (only with https) but right now it’s not working anymore. I wasted the last 3 days trying to get it working and only ended up creating more issues in Home Assistant. Now the whole thing isn’t working anymore.

As soon as I tried using duckdns, I was forced to use https locally but the SSL certificate isn’t even working. Without using https, chrome returns the error ERR_EMPTY_RESPONSE

Then today the issues got even worse. Home Assistant is not loading 90% of the time. Rebooting doesn’t help.
…and when I am finally able to log in I get a fcking “403: Forbidden” error on a white page.

I tried everything from deleting cookies to using another browser or private navigation tab, but I can’t even get the damn logs so how am I supposed to debug and troubleshoot…

Oh, and the mobile app? Nope, also not working.

I’m at the point I’m considering giving up on everything HA. Too many issues it’s an absolute nightmare and very hard to find any solution.

Sorry it works for me as advertised.

Https:// on local won’t work, use http.

Both aren’t working.

http://homeassistant.local:8123/ (no SSL)

https://homeassistant.local:8123/ (with SSL)

Use the IP address of your device for local.

Mine is

If your ssl certificate is it will mismatch if you use homeassistant.local

I think I found why I was getting 403 forbidden. For some reason HA was auto-banning myself. The only solution is to remove automatic IP-ban after X failed login attempts. Not sure if I want to use duckdns anymore if my control panel can be brute-forced so easily.

You’re right, the certificate is using duckdns

I think I’m onto something. The issue seems that I have a CODA-4589 Modem in front of my Eero router

Basically, my setup is
CODA Modem → Eero Router Mesh → Unmanaged Switch = CODA Modem = Eero Router = Home Assistant

I was doing the port forward in my Eero router. But according to something I found on Reddit, I think I am running into a “Double NAT” issue. If I understand correctly, I need to forward the CODA Modem to my Eero Router, and THEN from there to my HA server.

So I tried doing that by first logging in my modem and finding the Eero IP on the same subnet ( =

Then I set up the port forward but I’m not sure if I am forwarding the correct ports
I’m forwarding the modem ( to my Eero router ( /

However the open port tool still says my ports are closed.


If anyone come across this topic, the problem was definitely a “Double NAT” situation a.k.a. the Modem acting as a router and having another router (Eero). Solution is to put the router in bridge mode or IP Passthrough

I used IP Passthrough on my ISP Modem, and I set the Eero as my main router. Then I forwarded ports 80 and 443 to port 8123 on the Eero and IT WORKS!!!

For my ISP (Cogeco), these guides were helpful:

Glad you got it working.

Hi, can you show your final setup in eero. I enabled the Bridge Mode on my router but nothing works for me :frowning: