Purchased new HA Green, Supervisor updates fails

Followed steps easy 1-2-3 as in manual - connected to home internet router with ethernet cable, powered on, connected from PC web browser on the same network.
System Home Assistant supervisor version installed 2023.10.0, available version 2024.01.1. Attempt to update results in error (see below).
Googled several articles and decided to test with different network provider, different router. The same error. Changed to static IP - the same error.
Any advise how can I check if HA can communicate with internet? Obviously it works fine inside the local network.

Logger: async_upnp_client.ssdp
Source: runner.py:188
First occurred: 10 February 2024 at 00:19:34 (21 occurrences)
Last logged: 22:43:52
Received error: [Errno 101] Network unreachable, transport: <_SelectorDatagramTransport fd=31 read=polling write=<idle, bufsize=0>>, socket: <asyncio.TransportSocket fd=31, family=2, type=2, proto=0, laddr=(‘’, 43173)>
Received error: [Errno 99] Address not available, transport: <_SelectorDatagramTransport fd=30 read=polling write=<idle, bufsize=0>>, socket: <asyncio.TransportSocket fd=30, family=10, type=2, proto=0, laddr=(‘::’, 39224, 0, 0)>


Another attempt to update Surpervisor fails with this error:

Logger: homeassistant.components.websocket_api.http.connection
[281472972938816] Error updating Home Assistant Supervisor: Update of Supervisor failed: Can’t install ghcr.io/home-assistant/aarch64-hassio-supervisor:2024.01.1: 404 Client Error for http+docker://localhost/v1.43/images/ghcr.io/home-assistant/aarch64-hassio-supervisor:2024.01.1/json: Not Found (“No such image: Package aarch64-hassio-supervisor · GitHub”)


Figured out that HA has access to the internet, because 1) Weather forecast updates data, 2) Media - Radio Browser works and can stream internet radio.
Now, what’s wrong with Supervisor update for newly purchased HA Green?