Purge_keep_days somehow not obeyed (wth am I doing wrong?)

Ihave uptodate system, now installed recently victoria metrics db per instructions of that addon and added to my config

          purge_keep_days: 32

No errors reloading config etc (or does recorder need full reboot?)

Database seems to have data as expected. Still stuff older than 10 days keeps getting purged.

Wth am I doing wrong?

That is a setting for the Home Assistant Recorder database, not the VictoriaMetrics add-on.

Victoria Metrics does not replace the Home Assistant Recorder, it is an additional database.

To define your VictoriaMetrics retention see the add-on documentation: homeassistant-addon-victoriametrics/victoria-metrics/DOCS.md at a9ed3e4639097282a96275809a7a10a41b270f2d · fuslwusl/homeassistant-addon-victoriametrics · GitHub

recorder should still be used for the short term stuff shouldn’t it? Or does using alternative database somehow drop recorder from the loop?

Problem is over 10 days old stuff disappearing despite recorder set to 32 days and victoriametrics to 99years.

Recorder only affects the database that HA writes to, which in your case would be home-assistant.db. So when you go to the history tab in HA, you’ll be able to see 32 days of data if your system has been running with 32 in recorder for 32 days.

shouldn’t it still stop deleting stuff that is under 32 days old? Or does each datapoint have planned deletion time saved with it? Some 5 days since I changed the settings, shouldn’t I today have about 15day history available? (I have 10 days)

it only purges from homeassistant.db. Nothing else.

Yes, you should have about 15 days. If you don’t, you did something wrong. Did you restart after you made the change?

Only reload yaml config. Today full reboot. Tomorrow will reveal if I have 11 days…

When you add an integration for the first time, you have to restart. This is why it’s not working the way you expect. Restart and it will honor the new setting.


solution: needs real reboot restart not just yaml reload to change recorder retention setting

needs real reboot restart

Just need to restart HA, you don’t need to reboot the hardware.

yeah poor wording from me.