Push notifications not working beta 2.0.0 (44)

I changed my notifications to the new mobile_app componente.

But it stops working. I see my devices on the services

Then I get this in the log.

2019-05-02 20:20:45 ERROR (MainThread) [homeassistant.components.mobile_app.notify] Requested entity was not found.

Whats the problem

Related to this and logged here…

1 Like

Got the same issue, seems to work only when the app gets set up for the first time. After an app restart (doesn’t need to be force closed) notifications will stop working. Strangely on my wifes phone (same conditions, HA 0.92.2 and iOS 2.0 build 44) notifications seem to work fine. On both phones the integration was removed as well as reinstalled the app.

Will wait for a fix.

thanks, I will wait for ne fix, too.

I had no notification target too after deleting from known_devices, mobile_app, removing the integration and upgrading my Companion app to 44.

Here’s how I resolved it. I don’t know how reproducible it is but I fiddled for quite a while before trying this so I think it’s not a coincidence. By going to iOS settings -> Privacy and completely disabling Location Services, then re-enabling it, it looks like all interested Apps request an update. After that my notification target was available.

New build should improve things but I’m still working with Firebase on fixing the root cause.

1 Like

Unfortunately the problem persists with the latest build. When reinstalling the app with build 40 (and removing the mobile_app integrations first) notifications seem to work again. Seems to work until build 40, when installing 42, the sensors will be recreated and the problems start there).

Though what is really crazy is that my ipad air and my wifes iphone xs has no problems at all. Notifications work fine for those two devices. My iphone x however is the only device with these problems.
I have come to think about this and I recently updated my iphone X (been running ios betas for the last 5 years) maybe someone could confirm that they have this problem on a release build of ios 12?

Anyways great work Robbie, Great work, we will all patiently wait and the ones that don’t have the patience should leave HA :stuck_out_tongue:

I’m also still having this issue with the latest build 46.
After force quit the app it works for a few moments.

Someone here knows what this error indicates? Push notifications does not Work with beta 46 only with 1.5.1 (3) on the same device.

[homeassistant.components.homeassistant] Invalid config for [automation]: Service notify.mobile_app_jespers-iphone does not match format . for dictionary value @ data[‘action’][2][‘service’]. Got None. (See /home/homeassistant/.homeassistant/configuration.yaml, line 18)

Gotta provide your automation for us to be able to tell you what’s wrong. Please use backticks (`) around your code to properly format it.

solved it. It must have been a typo when getting the device name from dev tools.
Device name of my iphone was “jespers-iphone” but in dev tools now it says “jespers_iphone” :slight_smile:
Now I guess I have the same issue as in the other posts here. Notifications only worked the first time after setting it up.

Can you post your worming automation? I’m still fighting with mine but it’s probably in need of some reboots. I don’t get a notify service in the services list besides notify.notify, unless there’s a way to use that and no andevice specific notify service call. You working automation example would be a big help. Thanks!

Setup the app (the onboarding part) refresh the page by pulling down (after logging in) restart HA and you should have notify.mobile_app_NAMEHERE appear in the list. But it probably won’t work as there is a bug which is currently being worked on.

This did Work once but as jimz011 writes there seems to bug that has to be fixed.

  - alias: Startup notification
    trigger:
      - platform: homeassistant
        event: start
    action:
      - service: notify.mobile_app_jespers_iphone
        data:
          message: "HA Startup"

Seems to be fixed in build 52. All my devices work properly again now!

Edit: typo (build 52, instead of build 51)

Me too. Thanks robbie

Hey Rob thank you for all your hard work on this app. I just updated to build 52 and for some reason the app kept on crashing. I’m on ios 12.2 iphone 8 plus.