Push Notifications on Android App make a sound, but don't pop-up

I am successfully sending push notifications to the Android App; however, they only make a sound, they do not popup on the screen. Other push notifications (e.g. SMS) do indeed pop-up on the phone. Within the Settings->Apps&Notifications->HomeAssistant settings, I don’t see any options to encourage or prevent pop-ups of the push notifications. Is there something I’m missing ?

There alot of fun options in here ! It’s amusing to make the Android app talk via Text to Speech. But still having trouble getting the push notification to actually just pop-up (like an SMS message)

Aha! Figured it out.

On the Android Device, go to Settings->Apps&Notifications->HomeAssistant->AppNotifications

Then select the “General” category (this was my mistake, it didn’t feel like something with sub-settings underneath it, it just looks like an on/off switch. Click it, trust me).

Now select Importance=Urgent.

Yay !

Welcome to notification channels for android! Now you can create your own so only certain ones will pop-up and others won’t :slight_smile: More details about how to create them here:

Ah, interesting! So I think I was using a pre-created channel called “General”, and if desired, I’m able to create my own channels, and can then configure the behavior of those channels on the device itself ?

Devices that are on android 8.0+ MUST use notification channels so we have a default General channel for that. You are free to create as many channels as you like to keep the settings independent of one another.

1 Like