Qingping Air Monitor Lite Integration

Hello Community,

I have recently bought a Qingping Air Monitor Lite (Model: cgllc.airm.cgdn1
) and im having trouble on integrating it on my Home Assistant setup.

I couldn’t find a relevant HACS integration altough i can see that python miio supports it

Also tried about 20 times to connect via Homekit Controller, but still, no luck. It appears as available, only for some seconds during the interconnection with the Mi Home app / or the Qingping app. After those few seconds, Home app on the iPad also loses it’s connection with it.

I currently have it connected via the Mi Home app (via Clone App on Android) using CN server (the only way to get connected on it) and I’m able to read its metrics without any issue, but im stuck at that point.

My plan is to use it on an automation, as an extra trigger for my Xiaomi Air Purifier pro (zhimi.airpurifier.v7) that I already integrated successfully via xiaomi_miio

Any suggestions please?

I’m running my setup on vmWare Fusion on an iMac

Operating System
Home Assistant OS 5.11

Supervisor Version

Core Version

There is integration for cgllc.airm.cgdn1:
ha0y / xiaomi_miot_raw
I use it with sensor config sensor.yaml


i got mine today and successfully paired it to my Home Assistant, following this post

all I had to do is pair it via my iPhone Home App then remove it, immediately after that click the “Homekit Controller” integration in Home Assistant and it will show up

not sure if its HA bug or Qingping

1 Like

I already tried this, but although i get the device’s token from the mi home app and i also ping it on its local ip, i get a communication error “Unable to discover the device” via HA and via miiocli also. I use the app in the screenshot to retreive the token.

am i doing something wrong?Στιγμιότυπο 2021-02-20, 19.27.54

1 Like

Well, the thing is that the device is only discoverable in the iPad Home app for some seconds, ONLY during the pairing process with the Qingping app (after the step that you add the local network’s pass). Of course while its discoverable i trigger the pairing process, but it never completes sucessfully.

If i reset it and try again, it is again not discoverable on the iPad.

I also upgraded its firmware on the newest via the Qingping app.

When I try to pair via the Mi Home app, its not descoverable (like the Qingping process)

Any thoughts?

Finaly Solved!

My reply to you made me think of a bypass, wich worked on the 1st try!! :wink:

I resetted everything and triggered the Qingping app pairing process.

Immediately after the step of adding my local wifi pass, i disabled the wifi connection of my mobile phone (and mobile data just in case…)

So, i was right, its internal process of disabling the homekit availability broadcast, was not cut off, so i was able to pair it with my iPad home app, then remove it and finally add it as a homekit accessory on my HA.

Thanks again!


For token I use this integration https://github.com/AlexxIT/XiaomiGateway3
Integration can get token from Xiaomi cloud.
Unfortunately quingping device lost connection sometime (

The next thing i came accross is that when the device gets shut down and turn on again, it stops broadcasting new values towards home assistant.

No errors on the homekit integration, no errors in the logs in general, but values stop comming. :frowning:

Any thoughts?

I have the same problem here. I connected the Qingping Air monitor lite through homekit controller. After few days, 2 or 3 days, the device will be disconnected from the wifi router and no value updated on the home assistant.

Even the air monitor Wi-Fi logo is alive. But the monitor is not connected to the Wi-Fi router actually. The power cycle is not solving the problem all the time. The only temporary solution is re-pairing the device.

The customer service of the manufacturing said the Air monitor is using Bluetooth connection in Homekit mode and Wi-Fi connection on Miji mode. I think we can solve the connection problem in this way.

Hi Lester,

I think that this info about bluetooth and wifi they told you is not valid. It probably has to do only with the pairing process, but not with the data flow after that.

I also raised a ticket 10 days ago on Qingping HQ, and I’m discussing with one of the co-founders now to find a solution. I also identified a bug that they will fix on a later firmware upgrade.

I will inform you here, once I have an update.

I’ve been using the JQ300 which is hopeless. I’ve just received one of these and it was pretty simple to add to home assistant.

After the firmware update it now changes screens every few seconds which is quite irritating.

Hi Leo,

Thanks it worked! Updating every 3 secs, 3rd day in a row without losing data or wifi connection.

I had to

  1. Connect the Qingping via miHome but on china server.
  2. install the above integration you proposed via hacs
  3. use your sensor specs in my config.

One question
While I was testing the homekit mode I saw a property that was called like “air_quality_text” that i handled via a template sensor.
The values were obviously text and it was referring/related on the co2 levels. The only value I managed to grab via my test time was “good”

So, my question is, how did you end up in the piid and siid combination?
Is there any chance i could identify and onboard that property?

Thanks in advance,

Hi Nick
I copied config from example and did nothing.
So I have no ideas what piid and siid combination mean.
There is another integration al-one/hass-xiaomi-miot
I’m going to try it. May be it works fine

1 Like

Hi Nick,

Hope the future firmware upgrade can solve the problem.

Current, I updated the firmware version from 2.4.8 to 3.1.4.

The connection seems better than before and the Wi-Fi connection is still connected and sending out data in around 1 week.

Would it be possible to use ESPHOME to get the sensor data from this device? It already supports simular devices like the CGD1

1 Like

I updated the firmware of this to 3.6.7 and reconnected it to home assistant and it work for a few hours but then shows as unavailable.

This one works best for me

  1. You don’t have to edit config files
  2. All sensors have history
  3. You don’t need to update configuration each time device changes IP

I hope they fix CO2 sensor which is currently not showing, but temperature, humidity and battery - does.


I spoke with extension developer and he provided configuration that makes all sensors working

1 Like

I use miio integration and have CO2, PM2.5 and PM10. My automatisation works with PM sensors only.
There is no data about temperature and humidity from miio. :frowning:
I heard that there is PR for adding temperature and humidity sensor for miio, but it is not critical for me.

How did you manage to install this integration?
Button + on the github returns an error locally.
Also I was not able to find this integration in a list during adding integration process.
I am a little bit afraid of installing HACS and also using shell.
Any advice?