Qnap 233 NAS integration working?

Hi
I’m trying to add my qnap 233 NAS to HA using qnap integration
I’m putting the IP and user password of a user with access to the system
Getting unknown error and won’t add anything

See image

In HA log I see this error which I don’t understand

File “/usr/src/homeassistant/homeassistant/components/qnap/config_flow.py”, line 77, in async_step_user
unique_id = stats[“system”][“serial_number”]
~~~~~^^^^^^^^^^

Any idea what I’m configuring wrong?

BTW I can mount without problem into qnap from the HA terminal shell using the same IP and credentials

Having the same issue with my 431, so I filed a bug report as I couldn’t find similar in their tracker.

Make sure you have 2FA disabled on your QNAP because the integration won’t work with 2FA enabled.

Also as per HA’s QNAP integration page make sure you have completed the following:

2FA disabled, I’ve logged in as the user. Thanks for reminding me to add the version of QTS I’m running on the device to the bug report. But I’ve just realised what the problem was (at least for me), so I’m editing the bug report. User wasn’t a member of the Administrator group…

Do NOT disable 2FA. I use 2FA on mine and it is fully integrated without any issues. I might have re-enabled it after integrating it. There’s always some vulnerabilities on these devices so I recommend having MFA enabled, especially if it is internet facing. Edit - sorry this was wrong, I had a separate non-MFA account set up for the integration.

2 Likes

That is good news. When I configured the QNAP integration some years ago it always failed to connect. I will reenable 2FA :+1:t3:

Yes, please do. I am testing to integrate one of my other QNAPs right now - it might be that you need to disable MFA while you integrate and then re-enable it. I will post my findings in a couple of minutes.

1 Like

Unfortunately it seems to be like that. That is why my NAS devices never face the internet (internal access only). The Qnap as a media server and a Synology for NVR and HA-backups.

Yeah, I was wrong. I tried removing MFA on my other NAS, integrated it successfully and re-enabled it, everything went unavailable. Been years since I set it up on my main NAS, I see now that I’ve created a separate non-MFA account which I use for the integration. Sorry for the confusion!

That’s sad. I thought I can reenable 2FA. Thank you for confirming.

1 Like

Yeah, really not ideal not having MFA on these, I feel new vulnerabilities and exploits for QNAPs surface very often (SSH was the last one I think).

1 Like

I have never trusted the security of these commercial NAS devices. If they are not a temptation for intruders they might be a temptation for the preying eyes of the manufacturers themselves.

That is why for file sharing and collaborative working I have set up a Nextcloud Server on a dedicated root server with a hosting company.

1 Like

Yes I agree. All these “QNAP mycloud” services and so on are disabled here. I only have one port exposed which is not related to the NAS OS itself.

1 Like