Qnap 431P3 Docker HomeAssistant Core

Hi there,

I got a problem with my Homeassistant Docker installation.

Recently I switched from a Qnap TS-431P to a Qnap TS-431P3 (ARMHF → ARM32V7)

So I pulled the latest Docker Image and wanted to start it, but nothing happens. It seems like it is starting for a moment and stops.

On my search for my problem I found this topic:

patchelf issue with auditwheel

So is that my problem? Can I fix that stuff by myself?

Thanks for your help :slight_smile:

Honestly, it’s best to ask on the GitHub thread you posted as they appear to know the subject matter.

What docker image did you use?

Can you see in error in log. Not sure if qnap show log for docker container.

I used the latest image of HA.

https://hub.docker.com/r/homeassistant/home-assistant/tags

I can´t see any error logs…

But when I use the last docker image of linuxserver for arm32v7 everything works fine. Unfortunately Linuxserver set arm32v7 end of life…

Greetings

Breaking change

Docker image is posted on github not dockerhub

Tried also github with same result…

Edit: Perhaps that is also a thing? Warum werden die installierten Drittanbieter-Container auf bestimmten 32-Bit-ARM-Geräten nicht erfolgreich ausgeführt? | QNAP

Nobody can help?

Did you try homeassistant/armv7-homeassistant-base:2023.07.01 from github, will that work?

It was previously suggested to ask on github. If it only affect one device then it is special issue and without log we are just guessing the solution.

Thx I will try it. Yes I asked on Github seems like the problem is known but not fixed… :frowning: