Qubino Flush Shutter ZMNHCD1 doesn't work at all

Hi there,

I bought a Qubino Flush Shutter ZMNHCD1 in order to automate our shutters. I installed one test devices in a shutter socket and has also managed to add it in HA (please see following how it appears in HA).

Unfortunately, nothing happens when I push the up/down buttons.

Has anyone an idea what went wrong and how to fix it?

Thanks in advance.


Is there load connected to the shutter? Have you set the shutter to auto detect and configure the start and stop position? I forgot the parameter number but you need to do that sequence at least one time…

Edit: I thought it was called “calibration”.

Yes, there is load connected to the Qubino. I can use the shutter with the ild switch at the wall and I can hear the Qubino clicking.

Sorry, bur I neithwr know how to set the Qubino to auto detect nor how I enter the config/parameters of the Qubino as I am relatively new to the whole HA stuff. Do you have a hint how to do that?



Look at parameter 74 and 76.


Edit: 78 is calibration process.

Okay, thanks very much for the hint. It works now partially after I edited parameter no. 74 by filling in the down/up time.

Nevertheless, there is still an issue. I have a wall switch with two buttons connected to I1 and I2 port of the Qubino, one button for up and the other one for down. If I push one of these buttons, it stays in the position which I pushed it to. If I do not push back the button in its original position, the qubino will not respond to commands that I issue via Home Assistant. Only after I push it back, the Qubino reacts again on commands from HA.

Any ideas how to fix this issue too?

Well in my case i placed little springs in all rocker wall switches to turn them into push buttons. It was not that hard. All in all i have 12 shutters with ZMNCHD1s :slight_smile:

On my wall switches, it was very easy to place or take put that little springs since the manufacturer sells both bistable and push button type wall switches which use the same production; only 1 of them has a spring inside and the other one this spring taken out.

I too had a lot of problems with the configuration of bistable swicthes to work with ZMNCHD1. So that’s why i converted them all to push button types… I rememberf Qubino support guys were very helpful with this issue but whatever they proposed before, didn’t worked out for me…

I didn’t needed to edit parameter 74, just did the 78 calibration. Because the motor turns itself off when it reaches up or down position. I suppose yours should be the same since you have bistable switches…

1 Like

So all is solved now? Mark the post with the solution for others :slight_smile:

Okay, thanks for your feedback.

Strangely enough, it works now with the automated calibration with parameter 78, don‘t know exactly why.

As you appear to have plenty experience with the Qubino, could you perhaps also tell me how to read out the current level of the shutter percentagewise in HA‘s lovelace? There is the entity „cover.qubino_goap_zmnhcdx_flush_shutter_level“ but I cannot create a Lovelace card because the entity doesn‘t appear under „Gauge card configuration“.

Position should be an attribute of cover.xxx_level. If you create a template on position attribute, you can use that as a sensor for gauge. Percentage and position is already in the cover entity details in lovelace. But if you want to see it as a seperate entity, than i believe you can use this attribute.

UPDATE: It turns out the attribute name for the position is “current_position”…

Glad you got a solution. :smiley:

But - I’m lost here.
You had a problem…
You came to the forum…
… and received a lot of good help from individuals ( @sender and @febalci ) yet you marked your own post (with no solving information) as the solution.
You should mark the post that most helped you as the solution (read the guidelines and Tinkerer’s sticky at the top of the forum).
Ideally you should also post the full solution (eg if you sent a note to yourself, back in time as to all the steps you needed to undertake in order to reach what worked for you)
This way, somebody looking for a similar solution would gain the benefit of all the contributors and you will have added to the body of knowledge.


To be honest, I don‘t really know what finally has brought the solution.

My guess is that I made a mistake when I first edited parameter 78 and set it back to „default“ after setting it to „1“ and running the calibration process. The second time - after @febalci ‘s post -, I just set it to „1“ and not back to „default“.

Setting the up/down time over parameter 74 did not work properly for me. The shutter did not go entirely back up. I assume that was due to the fact that the up and down time differed.

Thus, since you were not aware I provided the solution thus? You just did not apply it properly initially.

Yes, you‘re right. Your hint on parameter 78 came first. So I marked your post with the solution tag. :slight_smile: Did not know that this is such a serious thing here…

And yes, it seems that I did not applied your solution properly at first.

@all: Thanks again for your help. I really appreciate it.

Its not so serious, but it helps others.