Question about sensor attributes


I’m writing a sensor that integrates with the Public Transport Victoria API, and I have a question about best practice for setting attributes.

Should they be named in snake case (ie lower case with underscores), or as more human readable names?

eg There is an attribute that represents a “Stop Name” - should I name that stop_name or “Stop Name”.

I suspect they should be snake case, so that they are easier to identify in scripts, but I just wanted to make sure.


I would have thought the attributes name need to be in the lowercase and underscore format as this is how all the attributes in my HA are defined.
Check the Dev docs, there may be something official, I’ve not looked myself

I can’t seem to see anything in the docs, though snake case looks like the way to go. I guess I can use a template to display something more friendly.