Question / Help request: Alexa Media Player HACS Integration Fails to Load at Startup

For the past 2 weeks I’ve been getting an error notification that my alexa media player is not available. When I go to the integrations and reload it, then it works fine. I just have to do it after every restart, which is every day. Here are my questions:

  1. Does anyone know the root cause or solution?

  2. If not, my next best thought was to build an automation that would reload the integration after the daily system restart. I have a template for a trigger at 2 minutes after startup. What I’m looking for now would be an action to reload the integration. Does anyone know if this is possible and if so, how?

There is an open issue, I did as you thought and created an automation (based on the below) to reload the integration 15s after home assistant startup (use any of your alexa media player entities)

- id: '171873758939587'
  alias: Alexa Media Player Startup
  description: Reloads alexa media player if the integration does not come online
  mode: single
  trigger:
  - platform: homeassistant
    event: start
  action:
  - delay:
      seconds: 15
  - service: homeassistant.reload_config_entry
    target:
      entity_id: media_player.alexa_workshop

@Holdestmade Thank you for the information. Just to clarify, does the automation have to reload each and every alexa device individually, or is there a way to reload the entire integration globally?

Just pick one and the whole integration will reload