Rachio sprinkler controller status is wrong

Hello all,
I am just getting started with HA. One problem I noticed right away, is that my Rachio often shows a zone is on when it is not. It seems to get stuck in this mode and I don’t know how to unstick it. My Rachio app is correct, just HA is wrong. I sometimes can fix it by restarting HA but not always. And refreshing things does not help.

Anyone know what is wrong and how I can fix this? I don’t really need control over the Rachio from within HA, but it is nice to see the status along with everything all in one place.


Hi, I’m having the same issue. Did you ever find a fix for this?

I never found a fix. However, the issue seemed to have gone away, I have not noticed incorrect status in a long time. Sorry I am not much help.

Thanks for the heads up. I guess I am where you were three years ago: my Rachio component is only reporting the correct status right after a restart. After that, no status updates, and switches do not do turn on sprinklers either. I guess it’s a matter of wait and see… Thanks!

In case this helps some other users… Turns out you need to setup your external web address and port number, after setting up port forwarding on your router. If not, Rachio cannot find your Home Assistant installation and use webhooks to update status, start zones, etc. So basically, to anybody using this component, you have to add

hass_url_override: "http://your.dns.address:XXXX"

to your config. XXXX is the outside port redirected to 8123 (it can also be 8123 - but not recommended). After that, Rachio component works like a charm.