Rademacher DuoFern


#41

Hey guys, anyone else having issues with 0.89?
Setup of duofern fails since then.

EDIT: Got it working, see referenced GitHub issue.


#42

Hi, I’m new to this thread and I would like to say thank you first for creating this component. I was using FHEM + MQTT as a bridge for a while, but this one is much better.

Yesterday I tried to move to this component and set it up like described here: https://github.com/gluap/pyduofern/tree/master/examples and after fiddling around I got working with hass.io - almost.

Almost because I can not control any roller shutter. Pairing worked well, all roller shutter actors appeared in HA, if I control a roller shutter via remote control I receive the updated position and open/close status in HA as well.

Only controlling via HA does not work. I already enabled debug log for the component and it looks like messages are send:

2019-03-14 14:17:16 DEBUG (SyncWorker_13) [/config/deps/lib/python3.7/site-packages/pyduofern/duofern_stick.py] sending 0D01070300000000000000000000006fdeda42597a00
2019-03-14 14:17:16 DEBUG (SyncWorker_13) [/config/deps/lib/python3.7/site-packages/pyduofern/duofern_stick.py] added 0D01070300000000000000000000006fdeda42597a00 to write queue
2019-03-14 14:17:16 INFO (Thread-3) [/config/deps/lib/python3.7/site-packages/pyduofern/duofern_stick.py] sending 0D01070300000000000000000000006fdeda42597a00 from write queue, 0 msgs left in queue
2019-03-14 14:17:16 DEBUG (Thread-3) [/config/deps/lib/python3.7/site-packages/pyduofern/duofern_stick.py] writing  0D01070300000000000000000000006fdeda42597a00
2019-03-14 14:17:18 DEBUG (Thread-3) [/config/deps/lib/python3.7/site-packages/pyduofern/duofern_stick.py] writing  81000000000000000000000000000000000000000000

But the roller shutters don’t move. Any idea?
Thx.


#43

Never mind I got it working using the same network code I used in the FHEM setup.


#44

@ gluap, Paul

The have changed the directory structure of custom components beginning with HA 0.88.

See blog post: https://developers.home-assistant.io/blog/2019/02/19/the-great-migration.html

Duofern is still working but needs to be modified to work with the new structure.

I have made the modification as suggested in the log and it is working as expected.

Are there any further modifications need to be done?

Could you please help and have a look at the issue?

2019-03-23 20:29:36 WARNING (MainThread) [homeassistant.loader] Integrations need to be in their own folder. Change cover/duofern.py to duofern/cover.py. This will stop working soon.


#45

Hey Tom, when did you setup/update your DuoFern custom component?

It seems your proposed change already exists in his GitHub repository: https://github.com/gluap/pyduofern/tree/master/examples/homeassistant/custom_components/duofern


#46

eXtatic you are right. I have installed it long time ago short after Paul has released the component.
After that I have done one or two updates. Since I haven’t looked in the repository for any updates again because the component was working without issues for me. This warning get my attention after I upgraded home assistant from 84.7 to 90.1. I had to modify some things due to breaking changes in the newer version so everything is working as expected again.


#47

After installing pyduofern-0.25 the cover isn’t detected anymore :frowning:

Successfully installed pyduofern-0.25

Error while setting up platform duofern

Traceback (most recent call last):
  File "/usr/local/lib/python3.5/dist-packages/homeassistant/helpers/entity_platform.py", line 128, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=hass.loop)
  File "/usr/lib/python3.5/asyncio/tasks.py", line 400, in wait_for
    return fut.result()
  File "/usr/lib/python3.5/asyncio/futures.py", line 293, in result
    raise self._exception
  File "/usr/lib/python3.5/concurrent/futures/thread.py", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/home/haadmin/.homeassistant/custom_components/duofern/cover.py", line 19, in setup_platform
    stick = hass.data[DOMAIN]['stick']
KeyError: 'duofern'

I have also replaced my old custom component files with the new files from github:

pyduofern/examples/homeassistant/custom_components/duofern/

What’s wrong? What must I do that the component is working again?


#48

Sorry, got it working. It is always good to read the documentation. :slight_smile: My configuration of the duofern component was wrong in my configuration.yaml file. The old configuration with “cover” did not work anymore. I have to use “duofern” instead.