Radiotherm entity / custom name

New user here, so apologies in advance for any ignorance.

Just installed a RadioTermostats CT50e. I gave it a static IP address, and added the following to my config:

  - platform: radiotherm
      - 192.168.x.x

On restart, the widget shows up in the UI Overview, and displays current data (cool!), but it has the default name of “thermostat-XX-XX-XX” (where 'XX’s are from the MAC address). I’d like to give it a meaningful name, like “Upstairs” (I’ll be adding another for “Downstairs” later)… but I can’t see an obvious way to do this. There is no entry for this device in my entity_registry. I do see “climate.thermostat_XX_XX_XX” in the entity list under “Logbook”, though.

I do see some of these in the log, which I think are new (since I added radiotherm this morning):

hass[5718]: 2019-06-07 12:38:47 ERROR (MainThread) [frontend.js.es5.201904270] http://myhassserver:8123/frontend_es5/app.a9d8342b.js:2:79851 Uncaught TypeError: Cannot convert undefined or null to object

I’m considering trying to manually hack it into .storage/core.entity_registry, but before I go there; am I missing something silly?

Additional: I was running 0.92.2. I just updated to 0.94.0. The problem remains. I turned off discovery, and the error mentioned above goes away, but the thermostat is still there, so I think that that error is unrelated.

You should be able to click the entity and click the cog icon to edit the friendly name and entity id.

I can’t find a cog icon anywhere. I’ve clicked all over. There’s a button with three dots that brings up a detail dialog, but I still don’t see a way to set a friendly name.


Might be a bug. I would suggest going to Configuration > Customization to edit the Name (Friendly Name) of the climate entity.

Ahh! I peeked under “Customize”, but I totally missed the entity menu in there. That works - thanks!

Seems it should have been possible from the overview (by clicking on the name?) - maybe the button for the detail popup clobbers the configuration one? Also still not sure why the entity is not in the registry.

There should have been a cog wheel on the entity when you clicked the three dots to make that change. Might be a bug with the component.