Rainmachine integration always returns "Invalid authentication"

Hello All,

First some needed information:


arch: aarch64
channel: stable
docker: 20.10.9
- reboot
- shutdown
- services
- network
- hostname
- timedate
- os_agent
- haos
hassos: "7.2"
homeassistant: 2021.12.10
hostname: homeassistant
logging: info
machine: raspberrypi3-64
operating_system: Home Assistant OS 7.2
state: running
supervisor: 2022.01.1
supported: true
- aarch64
- armv7
- armhf


  • Firmware version: 4.0.1163 (No updates)
  • Web UI Version: 1.31
  • Device model: 5
  • API: 4.6.1


I’m trying to install Rainmachine integration from the main integration page on my homeassistant. I get to the screen requesting Hostname, Password, and Port (8080). After entering this information correctly, I always get an “Invalid Authentication” error.

I tried logging in to the device using a browser (rainmachine:8080/ui) and the credentials work without any problems. I also tried:

curl -X POST -H "Content-Type: application/json" -d '{ "pwd": "xxxx", "remember":true}' --insecure https://rainmachine:8080/api/4/auth/login

and I get back the token without any issues, indicating that the authentication is working fine.

Any ideas on possible leads? I’m about to set up a fake webserver using SSL to see what the integration is sending. Also, could it be that my rainmachine device has a self-signed cert?


This looks like something you should open an issue on here

I wasn’t sure that this justified a bug report, the thinking being that it could be just something silly on my side. I’ll open the issue on github and we’ll go from there.