Random freezes RPi4+HASSos

Hello, does anybody have solution for random freezes of Raspberry Pi 4 running HassOS?
I am having issues where I need to unplug power to get it working again.
It freezes randomly every XY days. Soemtimes it works for 2 weeks fine, sometimes it freezes after few days. When it is frozen there are not services running like SMB share or SSH (connection refused). But it does respond to ping over wifi.

I tried different power supply and cable but it has no effect. Also tried to power it from powerbank connected to AC so the powerbank made UPS power source so hopefully any small power interruptions coming from wall should be filtered. It also didn’t chnge anything.

Is there anything you can suggest? I must make it more reliable because with HASS down I can’t control lights in my apartment and that is pretty bad. Specially when I am not at home as my wife is not really fan of my “stupid gadgets”…

Everything is updated to latest version but that is not the culprit - it is freezing for months now. But now it is starting to annoy me more and more as I have more critical devices controlled via HASS.

Can you connect a monitor to the pi to see any debug output when it freezes?

I can try to connect the monitor next time it freezes

Any more info about this freezing?
I also encounter this, more or less periodically.
My setup is RPI4 + SSD, Home Assistant running on docker.

I ran into the same problem running HassOS on a Pi 3B+. After noticing that the CPU NORMAL usage was over 100% I tried disabling some addons but no real change. Though after I changed the recorder to use a MySql server running on another host, my CPU usage dropped 75-90% and the freezes stopped occurring entirely.

I hope this helps.


Having the issue again right now. I don’t have physical access (on vacation right now) but it somewhat works but not fully.
From the behavior I see I suspect the SD card or something around the storage:

Webpage loads only on computers that had this loaded previously (probably needs some cached elements to be already loaded as it can’t download them). Also works in Android app.

I see current readings from thermometers connected via ESPhome and from Air purifiers.

Can control robotic vacuum, execute scripts, change air purifier settings, turn lights on/off.
Can’t load any history graph, go to “supervisor” menu (or any other menu like configuration, developer tools…), SSH onto the machine…
Samba does not work
zigbee2mqtt devices don’t work
netatmo component does not update

It is strange that last X freezes I got when I was not at home. Maybe it is just Murphy that I get the freeze when I can’t easily reboot the machine or it is somewhat related to remote access or maybe lack of input events - when I am at home there is lot of events from motion sensors.

How big was your recorder DB before you switched from SQLite to MySQL and what was your commit_interval set to?

CPU usage is not an issue for me, but CPU load is (HASS OS becomes unresponsive / then almost unusable / and is finally dead - starting every ~ 10 hours after last HA start) -.-

To be honest, I do not recall. I’ve actually found that the problem disappeared completely after I replaced the image with the RPi 64 version.

Update: 9/21: The problem returned and I gave up. I switched over to an ODRIOD-N2+ and have been very stable since the switch.

Update 6/19: I saw quite a few other people on different threads mentioning that they use SSD so I decided to switch back to a high endurance SD card and change the various configuration to ensure that it doesn’t write too much to the card. I’ve been up and running for two plus days without a crash which is better than before. It does seem to be stable. I’m not sure if my SSD was drawing too much power or there’s some flaw with the raspberry pi booting with the SSD but something does seem different after switching back to an SD card.

Update 6/10: I started having the problem again after about a week. And from that point forward it started crashing about every day. The next thing I’m going to try is to switch back to an SD card.

Original 5/17: I had the same problem and a completely fresh install (no snapshot restore) seems to have fixed it. It used to lock up every 24-48 hours but it’s been stable for over a week since a fresh install. Details here: HassIO stops responding every so often - #75 by bradymholt