Random UPnP/IGD Sensors


My Nighthawk X6 R8000 gets picked up by Integrations under UPnP/IGD.

However, its totally hit and miss to which sensors appear.

Overtime, the following sensors have appeared;

R8000 (Gateway) bytes received $
R8000 (Gateway) bytes sent %
R8000 (Gateway) kbyte/sec received $ %
R8000 (Gateway) kbyte/sec sent
R8000 (Gateway) packets received
R8000 (Gateway) packets sent $
R8000 (Gateway) packets/sec received
R8000 (Gateway) packets/sec sent %

At the time of starting this post, the only sensors providing values are the ones which I have put a $ next to above. However, I just restarted HA and now I get a totally different set of sensors reporting values - as shown by a % above.

Currently running HA 0.97.1, though this has happened ever since I started using IGD at around 0.90. I also had the same issue, using my Talk Talk D-Link Modem/Router so am guessing it is a generic issue covering lots of routers/modems.

My router does not support SNMP.

Any advise is much appreciated as though not interested in the 4 packet sensors, the throughput of the router would be of interest.

Kind regards

I haven’t used the integration myself but according to the docs you should be able to add sensors: false under the upnp: section in configuration.yaml to disable them.


Thanks for the reply. The point is that I want the sensors though.

Rather than letting Hassio find it automatically through the Integrations, ive also tried setting sensors to true under upnp in configuration.yaml too and still get very intermittent results as to which sensors decide to show!!

Kind regards

I have the same router and the same issue. I created mini graphs with the sent and received entities but sometimes they do not show up, in the end I gave up and just deleted the integration. Think the fault is with the router, I recently purchased it, I didn’t have this problem with old router

I was having the same issue with the standard D-Link router which Talk Talk supply with their Super Fiber. That was back at about 0.90 so I deleted it too then. But got the R8000 from Netgear about 6 weeks ago and thought id try with that again. Surely I cant be that unlucky twice and its something im doing wrong/something wrong in HA?

Same thing happens to me, it’s been driving me crazy trying to figure out where they’re coming from! Did anyone figure out how to keep them? It seems like every time I restart HASS i get a new sensor and lose one I want to keep.

This looks like the issue (which is still open)