Rasberry Pi 4 can't connect to lan


I am new to Hass and trying to get my Pi 4 to load. I have used several different SD Cards, PSU and connected an HDMI cable to see what happens and it will boot and get to the command prompt however nothing past that. I can detect it using the app FING and it shows a MAC address but no IP address.

I have tried 3 different networks with no success, please help.


Common tasks - Operating System - Home Assistant.

At the command prompt enter:

ha core check
ha core info

^ what he says! :slight_smile:

And please, give us more informations about your hard- and software and how you did the install, what version and installation mehtod you used and preferrably all the info you can think of. :slight_smile:

1 Like

Hi, Thanks for the mega fast reply.

When booting it states
“Failed to start network manager wait online”

64GB SD Card
Pi 4
HASS 12.1

Core Check retiurned a 500 server error

Core Info
arch : aarch64
ip_address of
port : 8123
ssl false
version landing page

Did you follow these installation instructions: Raspberry Pi - Home Assistant.

Also, anything in the logs?

ha core logs
ha supervisor logs

Hi Mark

Thanks and yes I followed the instructions and have read several places about problems with ethernet cables which I have tried swapping.

Core logs just say network is unreachable
Supervisor logs say -
Updater.fetch_data block from execution no supervisor internet connection
Warning supervisor.homeassistant.core error on Home Assistant installation retrying in 30sec

This is a network problem - not a RPi problem. A network connection is needed to set the time for the RPi. Try plugging a pc into the cable the Pi is connected to and see if you can get to the internet.


Yes I do get an internet connection. I have also tried connecting straight into my router and also I took it to work to try that as I had seen comments about Virgin Media routers.


Try all of these in this order:

ha core rebuild
ha supervisor repair
ha host reboot

It now has rebooted and come up with Error returned from Supervisor : System is not ready with state : Setup

From a browser, can you now get to xxx.xxx.xxx.xxx:8123 and ip-address:4357

1 Like

Afraid not, it won’t even show up info or anything as it Just returns

System is not ready withn state :start

When the command line appears, what are the ip addresses? Example:


They are blank for all lines

ha network info

Afraid it says

“System is not ready withn state :setup”

I can reinstall Hass

Reboot might help but rebuilding fresh is a good start. I would also check the router DHCP assignments to check for the mac address of the Pi4. Maybe a DHCP issue?

Thanks, that is what I thought however it was the same result when I took it to my work and plugged it in there. I guess both routers could have the same block.

I have got it to connect to the wifi and give me an ip address that way. Now I can access the Pi however only using port :4357 and not 8123. It gives the page

Home Assistant observer

Supervisor: Disconnected

Oooh but if I take the network cable out it connects fine