Raspbee + Rpi4 + config.txt = no boot

Hey guys,

So I’ve been at this for the last 8 hours and I’m going insane at this point. I’ve seen litterally all posts there are about raspbee, rpi4, hassio and editing config.txt file. My problem is that when I edit the config.txt file and add the two lines:


Rpi4 will not boot anymore. Yes I have added the two lines at the end and added a line/break/black after that. The real headache is: when I remove those two lines, it still doesn’t boot?! I am going insane with this and have re-flashes the SD card over 10 times now. Everytime I edit the config.txt it doesn’t boot, forcing me to re-flash and start all over again and try a different way of editing it.

So even though this is a Zigbee topic, I think the problem I’m having is bigger than that, since Rpi4 won’t boot after reverting the config.txt as well.

So my configuration:
SanDisk 32gb SD (90MB/s)
Raspberry Pi 4 - 4GB
Raspbee shield
Hassio 32bit for Rpi4
macOS used for editing config.txt
Synology text editor used for editing config.txt

I downloaded the config.txt file using my Synology usb port. Synology recognizes the boot partition when plugged in the sd->usb adapter. Then I edited it using TextEdit on macOS and one on Synology. Also uploaded it to Hassio using the Configurator add-on, then edited it there and downloaded it again and put it on SD using Synology sd-usb transfer. Thought perhaps editing it using Hassio would help, but it didn’t. Just to clarify: I am indeed editing the config.txt file from /boot partition.

I have two things to try: use a Windows machine and try to SSH. I don’t have a Windows machine atm (virtual didn’t boot). I couldn’t get SSH with private keys working (so I can SSH port 22222 to access /boot). With normal SSH I cannot locate /boot/config.txt. But I see people editing it on macOS so this is really confusing and frustrating.

Any thoughts? Or people who encounterd and solved this? All help is really appreciated!

This is my edited config.txt file btw: https://drive.google.com/file/d/1wllHr1vzJYJO1EEYubc9zKfXkHX444AR/view?usp=drivesdk

Have you tried a new image, and just enable SSH to the PI, then use raspi-config, to enable the uart etc.

All you need to do to enable ssh is to put a file call ssh into the /boot partition.

I would test if your RPI4 and PSU are OK by installing Raspbian on a spare SD card and then see if it boots OK.

Also SSH is better supported on MacOS compared to windows.

Thanks for the recommendations guys! I went ahead and installed Windows using Bootcamp to further troubleshoot. And that did the trick! I could just open /boot partition and edit the config file. Raspbee is also found and I can search and add new Zigbee devices using Dezonz on Hassio.

BUT: somehow; only lights actually work. Sensors are connected (when opening VNC) but don’t respond. Also I can’t seem to update the firmware. It says update done and after it’s reloader, it’s still on the old firmware. I don’t have anything plugged in the USB ports. So my original issue is solved, unfortunately my problems are not over yet. I will mark this as solved though, so others who encountered this can try this as well.

I’m thinking of just getting the Conbee II and return the Raspbee. That one worked first try with my setup and is going strong (this Raspbee setup is for my brother).

Any help is ofcourse appreciated still, perhaps I’ll start a different topic or edit this one.

Edit: I fixed this by this fellow community member’s guide.

FIrmware is now upgraded and sensors/switches actually work!

1 Like