Unable to detect lights using deCONZ

Hi All,

I am moving away from my hue and IKEA hubs and substituting them by a RaspBee + deCONZ, as I am planning to add Xiaomi sensors and I do not want a 3rd hub.

I am unable to detect any IKEA or Hue lights using deCONZ, and I cannot find anyone else with this problems, so this is what I do in the hope that someone can point my error.


  • Raspberry 4
  • RaspBee (BN-600052)
  • Light IKEA Tradfri 12W (980 lm)
  • Light Hue White Ambience


  • Hass.io 3.5 (Official, latest available currently)
  • Home Assistant 0.102.3 (latest available currently)
  • deCONZ add-on v3.8


  1. Flash new image to SD, insert and boot my RP4.
  2. Connect to RP4 using hassio.local:8123
  3. Add deCONZ add-on and followed configuration steps.
  4. Turn off Hue and IKEA hubs.
  5. Reset lights to factory settings (both Hue and IKEA)
  6. Click on ´Open Web UI´ in the deCONZ add-on to add lights.

This is where I get stuck as I cannot detect any lights.

I am sure the lights are in factory settings and they are in the same room as the RP4, so no range issues.

This is the Log from the deCONZ add-on, I guess something is not setup properly but cannot tell what:


00:48:44:096 wait reconnect 1 seconds
00:48:44:137 dev /dev/ttyAMA0
00:48:44:137 COM: /dev/ttyAMA0 / serialno: 
00:48:44:137 COM: --dev: /dev/ttyAMA0 (RaspBee)
00:48:44:347 try to reconnect to network try=1
00:48:44:627 device state timeout ignored in state 2
00:48:45:596 device state timeout ignored in state 2
00:48:46:596 device state timeout ignored in state 2
00:48:47:276 New websocket (state: 3) 
00:48:47:596 device state timeout ignored in state 2
00:48:48:596 device state timeout ignored in state 2
00:48:48:640 dev /dev/ttyAMA0
00:48:49:596 try to reconnect to network try=2
00:48:49:596 device state timeout (handled)
00:48:50:096 wait reconnect 15 seconds
00:48:50:096 void zmMaster::handleStateIdle(zmMaster::MasterEvent) not connected goto OFF state
00:48:50:096 device state timeout ignored in state 1
00:48:51:096 wait reconnect 14 seconds
00:48:52:096 wait reconnect 13 seconds
00:48:53:096 wait reconnect 12 seconds
00:48:54:096 wait reconnect 11 seconds
00:48:54:596 failed to reconnect to network try=3
00:48:55:096 wait reconnect 10 seconds
00:48:56:096 wait reconnect 9 seconds
00:48:57:096 wait reconnect 8 seconds
00:48:58:096 wait reconnect 7 seconds
00:48:58:636 dev /dev/ttyAMA0
00:48:59:097 wait reconnect 6 seconds
00:48:59:596 failed to reconnect to network try=4
00:49:00:096 wait reconnect 5 seconds
00:49:01:096 wait reconnect 4 seconds
00:49:02:096 wait reconnect 3 seconds
00:49:03:096 wait reconnect 2 seconds
00:49:04:096 wait reconnect 1 seconds
00:49:04:136 dev /dev/ttyAMA0
00:49:04:136 COM: /dev/ttyAMA0 / serialno: 
00:49:04:136 COM: --dev: /dev/ttyAMA0 (RaspBee)
00:49:04:596 try to reconnect to network try=5
00:49:04:623 device state timeout ignored in state 2
00:49:05:596 device state timeout ignored in state 2
00:49:06:596 device state timeout ignored in state 2
00:49:07:596 device state timeout ignored in state 2
00:49:08:596 device state timeout ignored in state 2
00:49:08:629 dev /dev/ttyAMA0
00:49:09:596 try to reconnect to network try=6
00:49:09:596 device state timeout (handled)
00:49:10:096 wait reconnect 15 seconds
00:49:10:096 void zmMaster::handleStateIdle(zmMaster::MasterEvent) not connected goto OFF state

Any suggestions on what I am doing wrong or missing?

Many thanks for your time,

Had same issue here.

Got a spare SD card?
Grab the Raspbian Buster Desktop image from here: https://phoscon.de/en/raspbee/sdcard

Use Etcher to write this image to your SD card and then boot the Pi off of it with a display.

After a few minutes it should detect your RaspBee and start updating the firmware. You will also notice the serial port is /dev/ttyS0 right? Weird… because when I check HassIO hardware list. It shows: /dev/ttyAMA0. But i ignore it for now.

so I tried to find the light bulb from IKEA there, works!

So went back to my Hass.IO SD card and made sure I had the following lines added to the config.txt file too:


Make sure there is an empty row below it. The config.txt should always have one empty row at the bottom of the file.

Boot up again raspberry pi with hass.io, go to your deCONZ. Reset your IKEA bulb by turning the light switch off and on for 6 times. Ending with the light being ON. You’ll see the bulb blink a bit, search for new devices, et voila! It shows!

1 Like

It works!

I think the bit that did the trick was adding to config.txt:


Funny enough, it is on the documentation but it says:

Using a RaspBee

If you are using RaspBee, you may need to edit the config.txt file in the root
of your SD card in order for your RaspBee to be recognized and assigned a device name.
Add following to your config.txt :


So since my device was recognised and assigned to /dev/ttyAMA0 I simply ignored that bit.

Many thanks for your help @Vasco !

1 Like

I am not lucky so far.
The deconz image is working (lacking Hass.io)
The hassio integration does not.

It seems the (my) hassio deconz plugin still does not recognize the RaspBee.
(I followed all that config stuff …)

E.g. checking “gateway” in the deconz plugin reports Version 2.05.71/17.11.2019 but the Firmware reports
“nicht verbunden” (not connected)

I am lost.

May I need somehow to reset the raspbee ? No glue.

Do I need to buy another board, one running the deconz image and one running the hass.io :frowning:

Someone any additional idea?

If the deconz image is working, the solution is simple : install hassio on top of it.

Finally I succeeded by using the hass.io image, deinstalling the deconz add_on and installed the marthoc/deconz docker stuff.
Anyway, currently all is in the test_lab environment.
I do still have some sd cards, so I may try @francisp suggestion as well.

Hey man, this really helped me! I couldn’t upgrade the firmware for the life of me. I could add all zigbee devices, but only use lights. Sensors/switches I could add, but they didn’t respond. I tried your way and could upgrade the firmware that way. After that I installed Hassio yet again (only one sd card with me) and now I can see I’m running the latest firmware and zigbee sensors/switches actually work! Thank you!

I’ve had the same issue on Raspberry Pi 4 with the latest hassio and deConz and I just realized what was wrong.

When opening the Hardware panel I have 2 devices listed under Serial:


I was just using the /dev/ttyAMA0 because it was the one I saw in the documentation. Only when I changed the config to use "device": "/dev/ttyS0" it started working.