Raspberry PI 3 4.2 image doesn't work

Bit disappointed really, I’m a relatively advanced user and so far cannot get homeassistant working after a few hours.
It’s a Raspberry pi 3 B+ so I downloaded image hassos_rpi3-4.12.img.gz
Unpacked the archive and then DD’s the image to the sdcard:
dd bs=4M if=/home/DVDs/hassos_rpi3-4.12.img of=/dev/mmcblk0 conv=fsync

Booted and saw the boot process, looks like it finishes fine apart from all the audit apparmor messages spewed onto screen.
I waited 30mins (I have fast wired connection so shouldn’t take it long) and still no web interface. Scanning the pi I get no listening tcp ports at all.
It got an IP as I saw it in my dhcp server, I can ping it.
If I login to console I get the ha-cli but doing any core info or check commands all just keep returning the help, nothing seems to work.
core status, core info logs, etc all return back with
dial tcp connect: connection refused.

There doesn’t appear to be any easy debugging to carry out or much I can do to debug whats gone wrong here.
Can any assistance be provided, and also perhaps update documentation as there is clearly something not quite right here with the recommended image for rpi.

How large is your sd card? What did you get when you try to access the web interface?
Don’t think it makes any difference but did you try to burn the image to the sd card instead of unpacking and dd? What do you get fron this command systemctl status hassos-supervisor?

thanks for replying.
SD card is 64Gb.
Nothing trying to hit the web interface, the tcp port 8123 isn’t listening which my nmap confirmed.

I’m sure the docker instance is running as I do get the homeassistant cli when logging in via console as root so I’m getting the “ha >” which proves docker is running?
Checking the supervisor status:

BUT that does show the date/time completely wrong, and that it cannot connect to
https :// version.home-assistant.io/stable.json

This suggests the timezone is wrong, as ntp did a sync but seems to be wrong.
I can ping google and version.home-assistant.io and get a reply so routing and internet connection seems fine so this looks like it’s relating to the clock.

What’s the simple way of setting the docker clock and/or container clock initially?

I’m getting somewhere. Not easy this at all.
Find the docker id:
docker container ls
Then use the ID to run a command in the docker instance:
docker exec -it 82cj(theidabove) date
And it shows the wrong date.
So to set it I then did:
docker exec -it 82cj(theidabove) /bin/bash
(To get a bash prompt in that instance)
and then set the date:
date -s “2020-08-17 12:00:05”
Date sets and it actually looks like it’s now working and doing stuff as I then saw various docker commands pushed to the cli.

Waiting to see if this worked.


As you are faniliar with linux and docker, maybe the Supervised install on top of a generic linux install is a better fit for you.


So, for the record if anyone has difficulty with the ‘easy’ pre-build RPI installs, the above date commands may help solve the problems. The web UI is working now.

@burningstone - thanks for the replies, unfortunately I went for the ‘easy’ option to avoid wasting lots of install time, conflicts on my existing servers, etc. In this case it ended up doing the opposite.
I more wanted to post this follow-up/reply for others struggling here.

1 Like

Is this a bug? It sure sounds like a bug. The user shouldn’t have to adjust the time like this in order for the system to work.

FWIW, I installed Home Assistant OS on an RPI3 about 3 months ago and didn’t need to tweak the date/time. Perhaps something has changed since then (and not for the better)?

Yes I suspect it is a bug as this isn’t the out-of-the-box experience expected!

I’ve also found, on reboot of the raspberry PI the TZ and date/time set fails again (not surprising) and so it won’t start up homeassist on reboot.
I’m trying to work out a clean way of fixing this. At present if I login on the console, go into the docker login and set the date/time manually each time by doing:
date -s “yyyy-mm-dd hh:mm:ss”

Then suddenly HA fires up and works fine (It’s timezone is wrong still on UTC but it works).

My guess is that at boot it tries to use ntpdate to sync date, however since the image date/time is so old ntp refuses as the time/date is too far in the future so it won’t sync. It therefore remains at an old date/time and everything fails SSL cert-wise due to the system date/time.

Howto solve? Not sure, I’m not experienced with Docker and the image here, so I’ll keep digging and try to find a solution.

(PS - Not quite the zero-touch install I was hoping for since i’ve now spent 4hrs working on getting this far)

The problem is that changes in the docker container will not persist after a restart of the container. The fix would need to be included in the image file.
I use Home Assistant Container (Core running in a docker environment) and I always mount /etc/localtime to the docker image, but I don’t know if this is possible with the Home Assistant OS version and whether this will fix your issues or not.