Raspberry pi 3 + Bluetooth

Hi there!

Am I missing something:
16-05-02 18:14:59 homeassistant.components.device_tracker.bluetooth_tracker: No bluetooth devices to track!
16-05-02 18:14:59 homeassistant.components.device_tracker: Error setting up platform bluetooth_tracker

installed using:
sudo apt-get update
sudo apt-get install python-pip python-dev ipython

sudo apt-get install bluetooth libbluetooth-dev
sudo pip install pybluez

The first time HA restart after set up bt tracker, put ypur devices in visible mode to make them appear.

Maybe you have to define your BT unit some place? I got the same error when I added the BT tracking without my USB BT device connected to my RPI 2.

Yes, I think I have to define my BT unit, but how? anyone using a pi3 BT?

I had the same error but on Rpi2 with Bluetooth USB dongle.
In my case, I am using Raspbian, and I had to got to the desktop(connected to a display - not remotely) and enable from the Bluetooth menu the service. None of the ssh tinkering worked.
I had not time to deep further this issue. But you may check it and let us know the result.

I have Jessie light installed… Installed the gui with no luck. Disabled bluetooth tracker :frowning:

Put device in discovery mode in close proximity to bluetooth.
Restart HA


Get the bluetooth mac address from the device.
prefix the mac address with BT_
add to known_devices.yam
Restart HA

  name: "jPhone BT"
  mac: BT_00:00:00:00:00:00
  track: yes
  hide_if_away: no

I’ll check into that :slight_smile:

any updates? worked?