Raspberry Pi 3 won't boot

Hi All
I am new to HA.I downloaded the Raspberry Pi 3 into Etcher, and wrote the image to the sd card.When I try to boot up, the Pi does not boot!
I have tried another programme on the Pi, and it works, so something is wrong with the way I am installing.
Can anyone help?


  1. maybe sound silly, but when you wrote the image did you checked if he card is not write protected?

  2. when you wrote the image with Balena Etcher did you used the PI3 image = https://github.com/home-assistant/operating-system/releases/download/8.1/haos_rpi3-64-8.1.img.xz and not the one for PI 4 ?

Thanks for your reply. The card was not locked, because archer was able to right to it :grinning:.
Yes that’s the image I used.
I will try again using a different card.
As a matter of interest, when I re inserted the card into my pc, the pc did not recognise as a boot card.
Is that normal?

  1. Correct IP used? Check with ping

  2. Http protocol used? (instead of https)

  3. Correct port used? (8123)

If your Pi has the IP (static or via dhcp), enter the following in the browser:

What error message does it come up with?

Edit: Pi Status LED?

Flashes 3x: start.elf not available
Flashes 4x: start.elf not started (SD card can also be defective)
Flashes 7x: kernel.img not available
Flashes 8x: SD not recognized. An update of the bootcode.bin or start.elf might help

Red LED:
4x long flashing, 4x short, 1x very long: Image cannot be recognized, reloading the image will help


Maybe he runs it headless…

@Eli: do you have a monitor attached to it and if so, do you get any output on the screen?
What are the LED’s on the RPi doing?

Thanks NIC
No Network activity lights on the Rp, so I think the pi is not booting.
If I insert another pi application , the pi works

Use Raspberry Pi OS – Raspberry Pi Official Pi-Imager

Choose OS → Other specific-purpose OS → Home Assistant → Home Assistant → For Rpi 3

The network comes up later in the boot process so that’s not a good indication.
To have a better understanding you can check the LED’s on the board.

Thanks Nic, only light on the Pi is the red power light.I used Rasberrys own image created, still no luck!!

Did you use the same, single SD card to test with the other program as well or another one?
Where are you now with this problem?

Have you seen @ErikSlevin his post and edit about the LED’s: Raspberry Pi 3 won't boot - #3 by Eli

Thanks for all your support Nic.
I got it sorted, it was a faulty SD Card!!!
Take care


Good you got it solved!
Important lesson when using flash memory: check if it’s not corrupted.

If you mark your answer as the solution it might help others & some will not waste time in trying to help you when not needed anymore.

1 Like

@Eli, please consider this:

I have the same problem on my pi4, how did you figure out it was a dodgy card with one program working and not HA? I’ve tried 2 different make cards and both boot the pi with raspbian but not HA and I’ve tried etcher and pi imager

1 Like

I have the same problem on my Vilros Raspberry Pi 3 too (https://vilros.com/products/raspberry-pi-3-model-b-basic-kit)
It loads Openhab, but not Home Assistant. Unfortunately the balena Etcher approach to installing Home Assistant also fails because it trips out when McAfee notices that trying to write to the MBR and I’m reluctant to over-ride that for security reasons.

Did you ever figure out a solution? Having the same problem