Raspberry Pi 3B, trying to set up Zigbee2MQTT addon, "Error while starting zigbee-herdsman", log included

Trying to setup HAOS on my Raspberry 3B. I had many problems during installation but somehow I got through all that… I added this repository to add the Zigbee2mqtt addon GitHub - zigbee2mqtt/hassio-zigbee2mqtt: Official Zigbee2MQTT Home Assistant add-on. I am starting the addon but it keeps giving me this same error. I searched the forum and Reddit but could not find any solution. Sometimes people mention commands but I dont know where to type the commands. I just bought a USB cable to eliminate potential interference issues. I also tried another cable with my 20W charger but still the same error.

Here is the log

[18:31:43] INFO: Preparing to start...
[18:31:45] INFO: Socat not enabled
[18:31:50] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:info  2024-01-30 18:32:08: Logging to console and directory: '/config/zigbee2mqtt/log/2024-01-30.18-32-07' filename: log.txt
Zigbee2MQTT:info  2024-01-30 18:32:08: Starting Zigbee2MQTT version 1.35.1 (commit #unknown)
Zigbee2MQTT:info  2024-01-30 18:32:08: Starting zigbee-herdsman (0.30.0)
Zigbee2MQTT:error 2024-01-30 18:32:11: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2024-01-30 18:32:11: Failed to start zigbee
Zigbee2MQTT:error 2024-01-30 18:32:11: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2024-01-30 18:32:11: Exiting...
Zigbee2MQTT:error 2024-01-30 18:32:11: Error: spawn udevadm ENOENT
    at Process.ChildProcess._handle.onexit (node:internal/child_process:284:19)
    at onErrorNT (node:internal/child_process:477:16)
    at processTicksAndRejections (node:internal/process/task_queues:82:21)


I am using a Sonoff Zigbee 3.0 dongle plus

What is you configuration look like? Here’s mine below and after days of struggling. I move the USB plug to another port and magically it worked without even changing the port ID. This is on a Pi 3B+

This is my config, the addon is has not been started and I turnbed off ZHA (another thread suggested it). But I laso treid with ZHA on. I also changed the USB ports. I am not sure if it need some “spcial combination” for it to work…

you have not done your config yet. mqtt and serial are still empty. You need to fill them.
As for ZHA. disable it or delete it. You can’t have 2 ZigBee coordinators running on the same stick at the same time.
Not sure which Sonoff dongle you are using but here’s a youtube video for Dongle E. https://www.youtube.com/watch?v=4y_dDgo0i2g

1 Like