Raspberry Pi 4 B New HASS OS Install Not Booting: No HDMI Output, No Network

After misconfiguring some devices and blowing up my HASS database to 4+ GB, the performance of the web UI was very poor. I figured I probably burned through my SD card’s life as well, so I took a backup and tried flashing a new HAOS image to a new SD card. I tried three separate “Gigastone” 32 GB cards, and both the x86 and x64 versions of both HAOS 6.4 and 6.5. None of them output any video over HDMI, and none of them came online on my network after 30+ mins of waiting. I’m still using the same RPi and it has a DHCP reservation, but I did check my pfsense firewall for new DHCP leases just to be certain and there were no new/unrecognized ones. As a last resort, I took the 64 GB Samsung SD card that I had my original HAOS install on and flashed a new version over that, and it too is showing the same issues. Prior to overwriting my old HAOS install, it did output video via HDMI. For the sake of completeness, nothing else changed with my setup. For power I’m using a LoveRPi PoE hat.

What’s my next troubleshooting step?

What state are the LEDs in?

Have you measured the power supply output voltage?

Tried another power supply?

Solid green LED on the PoE hat and solid red LED on the Pi itself. No amber/status LED at any point. (I was getting a flashing amber LED on my old HAOS install before overwriting it.) UniFi says it’s pulling 3.33 W over PoE, and the only other thing on the switch (USW-24-POE, 95 W capacity) is my Wi-Fi AP, pulling 5.38 W.

Oh, another bit of info: Raspbian boots without issue with all other factors being kept the same, including the specific SD cards I tried to use for HAOS.

x86 and x86 are intel/amd. You need the specific aarch64 version.

1 Like

Sorry, I’m so used to using those as generic terms for 32- and 64-bit that I forget they do refer to specific instruction sets. I did use the appropriate RPi images from that link:

Flashed the backup I took of the old SD card back onto it and HAOS comes right up as expected. I really don’t want to keep running it on a dying SD card though. And of course I put it on the biggest card I have…

Old, working HAOS install on old, dying SD card:

So what would cause a fresh HAOS install to fail across multiple SD cards from different manufacturers, including one card that works with my old install, when all other factors are held constant?

Found and tried some other SD cards, also to no avail. I’m at a loss at this point. Guess I’ll open a bug on GitHub.

And if you flash your backup to a new card ?

Sadly I do not have another SD card large enough to flash the image 1:1. I was considering booting into a gparted boot disk to shrink the filesystem so it’d fit on one of my smaller cards, but all this seems like a lot of effort for something that’s supposed to be:

  1. Flash OS onto SD card
  2. Put SD card in Pi
  3. Profit

The top one in that image will definitely not work, it is for a Pi 1, the second should work. (Each HA OS image is tied to one model Pi, and will not work on any other model)
Maybe try downloading the image first, and flash from the local image.

Yeah, I did notice that mistake. I again tried both 32- and 64-bit versions, though this time only 6.5. Still with no luck.


Decided to just bite the bullet and shrink the filesystem with gparted, then dd that onto a new SD card. Still no idea what the problem was, but at least it’s back up and on a new card. Thanks for the suggestions, all.