Raspberry Pi 4 boot from SSD

Hi Guys
Which image of HA do I use to run HA from SSD on my raspberry pi 4. I have updated the firmware of my PI and enabled USB boot.
I have tried the Raspberry Pi 4 Model B 32 bit and it does not boot.


Since about a week ago I’ve been using the 64 bit version of HassOS 5.3 on an RPi 4 4GB. It seems very stable, once I worked out that I needed to modify my Aeotec Z-Stick. I migrated my system from a docker installation on a standard Linux desktop machine (an old Dell server).

You need to take HassOS version 5.1 or later.
Install it to SD card and clone it to SSD after that

My route was to install standard Raspbian on an SD card just so I could boot and update the RPi firmware to support USB boot. Then I wrote the Hassios image to the SSD directly using the Raspberry Pi Imager application on my Mac, with the SSD plugged into the Mac. You have to click the “CHOOSE OS” button, scroll to the bottom and pick “Use custom” and select your image file. Then click “CHOOSE SD CARD” and pick your SSD drive. Then click “WRITE”.

With the SSD plugged into the RPi and the SD card removed, it just worked.

One other thing I just remembered, the RPi refused to boot from SSD while I had an old USB keyboard connected. It worked fine to plug the keyboard in once it was running, but it wouldn’t boot with it connected. Now it’s set up correctly I don’t need the keyboard (or monitor) anyway.

Hi Guys I load Raspberry pi on SSD drive and the pi booted fine and I could login to pi.
Then I removed the raspberry pi software from SSD and Loaded Home assistant 5.1 on the SSD however pi will not boot with HA ? However its the same SSD & same pi 4.
Any idea why why HA would not boot ?

Hi Guys
Eventually, got the PI to boot, now how do I upload my previous Snapshots to my new HA installation?