Raspberry Pi 4 HA OS image does not boot from SSD

Hello, I tested HA OS image on Raspberry 3 B+ SSD and it booted without any problem. With Raspberry 4 the image for RPi 4 32bit does not boot. Hardware is configured correctly, if I image Raspbian to SSD then hardware boots from SSD without any problem. So I think that 32bit HA OS image is the problem. I do not want to use 64bit, because RPi 3B+ is crashing and the cause could be 64bit OS.

I could never get any of the 32 bit version of 5.x updates to boot from SSD. I was told the latest version has this capability. Well not for me. You may want to boot from your sd and use the partition utility and move everything else to SSD.

I have been using 64 bit on Rpi4 since the beginning of version 5.0 and I have never had a system crash. Today I am on version 5.12 and everything works perfectly.

Can you post your configuration on issue:


in this sheet


So we can compare what is different? Thanks.

I added the configuration to the worksheet. You can compare.
Personally, I think it depends most on the sata adapter.

Added my setup too, im using this adapter

Followed this tutorial:

read a lot of people having troubles with low amp power supplies. hope it helps

I wish that was the case. I have tried to different StarTech and both are listed as supported. Power supply is 3.5A.

Hi, I’ve been using it for a few months and all works fine without any problem.
I share my config to the worksheet if it could be useful, and I would like to recommend to insert the column with the adapter model also.
I’ve always used the 64bit version because it was the recommended one to boot from usb on Pi4.
I’ve tried different adapters (Startech, Eluteng, Jmicron, Sitecom) and all works good with Startech and Eluteng, with the others I have had several problems, and in some cases (Jmicron) I had to enable trim and quirks to make it works.
I think your problem is only with the 32bit version, not the adapter.

I am on the 64 bit version. Have been on since Nov when I went to the SSD. I have the StarTech 3.1. My Pi4 locks up in 3 hours to a couple of days using any version above 5.4. No issues on 5.4 and any 5.x below.

Thank you for filling it out. I am now wondering if it is related to the 8G vs 4G memory. The 8G is version 1.4 of the PCB where the 4G is either 1.1 or 1.2. I have not seen many people with the 8G version with this issue, but I have seen a lot with the 4G. Maybe something was changed on the PCB that Raspberry is not releasing. It still is strange why the majority of people using the 4G version work with no issues up to OS version 5.4.

Yes, it is true that I used Rpi4 4GB until version 5.3. I bought Rpi4 8GB and installed the configuration from the original. I used Rpi4 4GB on the LMS server and I can’t try it on later versions.

Could be how the memory is handled or a change in the board itself (resistor values) that is effecting timing. I have asked in the Raspberry forums and waiting for a reply. Who knows? I was told that the newer version of the OS / 32 bit would support SSD booting. I would like to try this next but so far, none of them boot for me.

Yes, there are a lot of variables from the board and other components. I don’t know if 64bit will have any advantage in the future, but I went this route and I’m satisfied.

There was no choice at the time. 64 was the only way to boot from SSD. I believe for the 8G version you need the 64bit to address the memory correctly. I only have one program that needs 64 (Visual Studio Code) and could live without it going to 32 bit fixes my lockup.

I had stability problems with RPi and had to move to Virtual Box. I had crashes with all different configurations:
RPi 3B+ 32bit on SSD: Crashing within 1 day
RPi 3B+ 64bit on SSD: Crashing within 1 day
RPi 4 4MB 32bit: does not even boot from SSD
RPi 4 4MB 64bit on SSD: Crashing within 1 day

Where do I get stable core 5.4 for experimenting? Best would be for RPi3 so I can use beatiful ELEMENT14 Pi-Desktop, which fits LoRa-MQTT gateway inside, made from ESP32 LoRa board.

Nope, the HA OS 32bit on RasPi 3B+ did not last even for 24 hours and crashed. Back to VirtualBox…