Raspberry PI 4 Stuck on Preparing HA

I used the raspberry pi imager to load HA onto a micro SD of a pi 4 and booted up the pi. I waited over night and still stuck on preparing HA screen. I tried a brand new sd card and did the same steps only to be stuck with the same error.

When I type in supervisor log I get the following repeated over and over:

WARNING (MainThread) [supervisor.jobs] 'Updater.fetch_data' blocked from execution, no supervisor internet connection
WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30 sec

I have researched this and found a number of bugs with no real resolved issues. I see one around a potential date/time issue but I dont know how to ssh and change it or if that’s even the issue?

From a command line on the rpi try to ping and also google.com. If the first works but not the second, then it is your DNS settings

Thanks I pinged both and it says for both “is live!” so it looks like its getting a response. There are alot of chatter about time settings anything else I can try? I just dont know specifically how to make any changes in regards to time all my commands fail.

Ok try this command from the command line to see the cpu percentage and the processes:


or to see all processes:

ps aux

Is the CPU spiked? I would look to see what kind of utilities you can fins that would check the hardware as well. If you don’t want to kill yourself looking if you cannot find anything, get yourself some better hardware. I am going to implement some video but before that I cannot use the rpi so I am going to have to upgrade my hardware. I am thinking of a Mini PC Beelink SER3 AMD Ryzen