Raspberry Pi 4 with Hass.io having periodic high load and slowdowns

I have a Raspberry Pi 4, and recently it has started to act very sluggish. During that time I found that the system load jumps up for a while. It isn’t processor use, but instead I/O use. After a while the issue goes away and the system is happy again.

My home assistant db file is about 2.8 gig.

Any ideas on how to track this down?

I am getting the same, very sluggish, automation delays and numerous errors in the log stating sensors taking longer than expected etc.

I ended up deleting my db file and rebooting, this fixed it for now?

Tried going thru my homeassistant log but its gobbledegook to me and cannot see anything obvious.

1 Like

Deleting the db and rebooting has seemed to fix the issue for now.

I also had this issue 2 weeks ago. I found out my sd card was the issue. It had terrible write speeds suddenly, which caused hangups with system and logger, resulting in huge spikes. Created a snapshot, used a brand new sd card and all was smooth again.

The corrupt one had write speeds of 0.5-2MB/s speed suddenly.