Raspberry pi as HASS Slave


I’m running a hass on my main linux server and now Im trying to add a pi as slave.
When I run “python3 slave.py” its just “hangs” without any log in the ssh. If i CTRL+C-it, this is the output:

pi@raspberrypi:~/.homeassistant $ python3 slave.py

^CTraceback (most recent call last):
File “slave.py”, line 9, in
hass = remote.HomeAssistant(remote_api)
File “/usr/local/lib/python3.4/dist-packages/homeassistant/remote.py”, line 135, in init
self.states = StateMachine(self.bus, self.loop, self.remote_api)
File “/usr/local/lib/python3.4/dist-packages/homeassistant/remote.py”, line 272, in init
bus.listen(ha.EVENT_STATE_CHANGED, self._state_changed_listener)
File “/usr/local/lib/python3.4/dist-packages/homeassistant/core.py”, line 455, in listen
self._hass.loop, self.async_listen, event_type, listener).result()
File “/usr/lib/python3.4/concurrent/futures/_base.py”, line 397, in result
File “/usr/lib/python3.4/threading.py”, line 290, in wait

Wheres my fuckup? :slight_smile:

Edit: Also the webinterface can’t be reached.

I have the same issue actually. Not sure where I’ve gone wrong.

Hello. Same for me. Unable to use any slave.

I have tried too. If anyone has done it or figures it out please update the website on Github or create a tutorial. Thanks!!

Appreciate the feedbacks guys. I’m going to make a bugriport on github!


I have been trying to setup a master slave for a day or so. I found the slave.py code in the link below gives feedback and connects with master. I am having other issues but seems fixable when i have time. It appears that this part of HA is not fully developed or maintained.



Thanks for the link, still got stuck at

pi@HASS-Slave2:~ $ python3 hass-slave.py
INFO:urllib3.connectionpool:Starting new HTTP connection (1):
DEBUG:urllib3.connectionpool:"GET /api/ HTTP/1.1" 200 27
DEBUG:asyncio:Using selector: EpollSelector
INFO:urllib3.connectionpool:Starting new HTTP connection (1):
DEBUG:urllib3.connectionpool:"GET /api/states HTTP/1.1" 200 29948


Now its stuck at cannot_connect. It might be because my master HA is on SSL…

Someone got past this? I also stalled here

It would be great if you could update the documentation with a working example.

I gave up on a slave / master and went with this route for now.