Raspberry PI camera components error message

HI everyone,

I have a raspberry PI install running 0.21.0 I used the all in one installer on top of Jessie lite …I am now adding the raspberry camera component and I am getting this error in my log when I start HASS …

16-06-09 13:47:18 homeassistant.components.camera.rpi_camera: Error: file path is not writable

I was wondering if anybody can help me fix it

I have specified the path and removed the path with “file_path: /tmp/image.jpg” entry and it does not seem to make any difference i still get the error when booting
I have tried changing and setting the permissions on the folder locations no luck

I can use the pi / hass account to manually take a photo and video and save it to the “file_path: /tmp/image.jpg” location

I am fairly new to linux so if anybody has any ideas please be very descriptive or just reply with actual commands to try

I would love to get this working

Thanks in advance

The rpi platform allows you to integrate the Raspberry Pi camera into Home Assistant. This component uses the application “raspistill” to store the image from camera.

If the raspistill application is installed all that’s needed is to point it at the location raspistill is saving it’s temporary file.

I think the file needs to exist and be owned by the hass user.

Try this:

rm /tmp/image.png
sudo su -s /bin/bash hass
touch /tmp/image.png


So I have set-up a folder in /home/hass/picam/image.jpg and added that to the config file …

and then did the touch file …thing and I could touch the file

saved the file did a restart of HASS and …

it all works …YAY …thanks guys …I am sure I tried that before and it did not work but maybe i had typo …

Thanks @Froz, this was also a solution for my problem! :grinning:

Hi, I working with pi camera project and I got this error : home assistant.bootstrap: Invalid config for [camera.rpi_camera]: not a file for dictionary value @ data[‘file_path’]. Got ‘/tmp/image.jpg’
Any help?

I have done all this and still not working. HASS is not creating the jpg file. If I sudo su -s /bin/bash hass then run raspistill the image file is created and shows up on the webpage. Not sure if it matters, I installed the all-in-one raspberry pi installation of HASS, should I be doing anything different ?

works! thanks a lot