Raspberry Pi install failing

Just got my first raspberry pi and installed the full raspbian jessie onto it. Im trying to install home assistant using the all-in-one installer and im getting this


Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 290, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1178, in prepare_files
    url = finder.find_requirement(req_to_install, upgrade=self.upgrade)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 194, in find_requirement
    page = self._get_page(main_index_url, req)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 568, in _get_page
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 694, in get_page
    req, link, "connection error: %s" % exc, url,
TypeError: __str__ returned non-string (type Error)

Storing debug log for failure in /root/.pip/pip.log

When i first got the pi it had “noobs” on it and i used that to install raspbian. Ran into this issue so i thought maybe i should try getting the image directly from the raspbian site and loading it myself. So i finished doing that but im still having the exact same issue as before. I’ve watched 3 different tutorials from bruh and followed the instructions that are given for installing to raspberry pi on home assistant website. Any help is appreciated.

Similar problem here. I have Jessi Lite on Raspberry model 1B. I run HA all in one installation. After 8 hours it is not finished and in instalation-report.txt there is last line: Running setup.py bdist_wheel for cython …

Any idea?

follow exact https://www.youtube.com/watch?v=VGl3KTrYo6s this video. AND do use winscp and win32diskimanager to extract the jessie image. All other images will give probs.

  1. I download Raspbian Jessie Lite from https://www.raspberrypi.org/downloads/raspbian/
  2. I create SD card using win32disk imager
  3. I insert the card into Raspberry Pi (model 1 B), turn raspberry on
  4. After a few seconds I can log in using SSH
  5. I make sudo raspi-config, expand filesystem, overclock to moderate (without voltage change), change timezone, finish - it restarts
  6. after restart I log in again using SSH
  7. sudo apt-get update
  8. sudo apt-get upgrade
  9. sudo reboot
  10. wget -Nnv https://raw.githubusercontent.com/home-assistant/fabric-home-assistant/master/hass_rpi_installer.sh && bash hass_rpi_installer.sh

… and after some time…
Running setup.py bdist_wheel for cython … and this is all, installation stops and nothing more happens.

Can someone confirm I do all the steps properly? Thank you

I have the same issue ;( seems your not alone…

I just said screw it and went with the hasbian image instead. Tried manual, tried aio installer, they kept failing over and over so now I tried the hasbian image and I have Hass running on my pi finally

The initial post shows that the install was possibly made using the root user. That will make the installer fail. You must use the pi user.

@IKROWNI Where did you find a hassbian image?

I guess i spoke to soon i just tried to upgrade hass after installing the hassbian image and now im getting this.

Installing collected packages: homeassistant, voluptuous, typing, pytz, requests, jinja2, pip, pyyaml, setuptools, MarkupSafe
Cleaning up...
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/usr/lib/python3/dist-packages/pip/commands/install.py", line 295, in run
    requirement_set.install(install_options, global_options, root=options.root_path)
  File "/usr/lib/python3/dist-packages/pip/req.py", line 1436, in install
    requirement.install(install_options, global_options, *args, **kwargs)
  File "/usr/lib/python3/dist-packages/pip/req.py", line 672, in install
    self.move_wheel_files(self.source_dir, root=root)
  File "/usr/lib/python3/dist-packages/pip/req.py", line 902, in move_wheel_files
  File "/usr/lib/python3/dist-packages/pip/wheel.py", line 348, in move_wheel_files
    generated.extend(maker.make_multiple(['%s = %s' % kv for kv in console.items()]))
  File "/usr/share/python-wheels/distlib-0.1.9-py2.py3-none-any.whl/distlib/scripts.py", line 322, in make_multiple
    filenames.extend(self.make(specification, options))
  File "/usr/share/python-wheels/distlib-0.1.9-py2.py3-none-any.whl/distlib/scripts.py", line 311, in make
    self._make_script(entry, filenames, options=options)
  File "/usr/share/python-wheels/distlib-0.1.9-py2.py3-none-any.whl/distlib/scripts.py", line 215, in _make_script
    self._write_script(scriptnames, shebang, script, filenames, ext)
  File "/usr/share/python-wheels/distlib-0.1.9-py2.py3-none-any.whl/distlib/scripts.py", line 195, in _write_script
    self._fileop.write_binary_file(outname, script_bytes)
  File "/usr/share/python-wheels/distlib-0.1.9-py2.py3-none-any.whl/distlib/util.py", line 384, in write_binary_file
    with open(path, 'wb') as f:
PermissionError: [Errno 13] Permission denied: '/usr/local/bin/hass'

the image can be found here

Hassbian Image

EDIT: After rebooting i see that hass is now showing as 0.29.3 so i guess it did update properly?

@IKROWNI The permission error would potentially happen if you didn’t stop hass before you updated. The hass file would have been in use.

I have the same problem, I alredy usado the Jessi lite and the complete version, and I get the error in both.
Can I get the old version of Hass?

sudo pip3 install homeassistant==0.XX.X

Replace the xx.x with the version you want. I’m not sure it’s just home assistant though. Seems to be other issues with python and others.

Boys it takes more than 20 hours to finish installation of Raspberry Pi All-In-One Installer on Raspberry Pi model B (yes the first version). Maybe you should change the text on Raspberry Pi All-In-One Installer page saying it takes 1 - 2 hours or try to install again on your raspberry - maybe something went wrong with new versions. Installation is really problematic.

btw. Could anyone provide his image for Raspy 1 in some minimal configuration which is really running without problems?