Raspberry Pi Install: not on network

Hi. New to Home assistant.

Problem: My Home Assistant raspberry pi is not even showing up on the network. I have an Eero router and cannot find it when connecting the pi to the network, even though network cables light up.


  • Raspberri pi 4
  • Burned the Home Assistant OS to a new SD card using Balena Etcher. I had to use a friend’s PC because my machine (a mac) has corporate restrictions.
  • It took FOREVER to burn Home Assistant to the SD card. Is this typical? like 60 minutes (we do have slow-ass internet, but still, 60 minutes?) ← I think this is the issue, but want some validation.
  • Stuck in the SD card to the Pi and assembled my case.
  • Started it up, connected to my ethernet hub.
  • Verified that the lights to the ethernet came on.
  • Failed to connect via a browser to homeassistant:8123 or to homeassistant.local:8123
  • Could NOT see any new device on the Eero network.

Is it possible to just use an HDMI cable to open a shell to the Raspberry Pi with HA on it so I can try getting the IP that way? Do you think I should try burning the HA OS again, and if so, should I first reformat my card? (I will need to borrow a friend’s computer to do this.)

Thanks for your help.

Instead of using Balena Etcher to download the file, just go directly to that URL in a web browser and it should automatically download the file into your downloads folder. It should be named haos_rpi4-64-9.5.img.xz
Once it’s downloaded, launch Balena and select the option to ‘Flash from File’ instead of ‘Flash from URL’, and browse to your downloads folder. Since the file is now local the flash should go much faster and less likely to be corrupted due to a poor internet connection.

Edit: You can use a USB thumb drive to copy the downloaded file onto and flash it on a different computer. Balena will automatically format the SD card as it burns the image.

1 Like

This is super helpful, thanks! I’m trying it out now.

Yes you can attach an HDMI monitor/TV etc to the pi. I think the pi will only see it if it is connected on boot.

USB keybd helps too :slight_smile:

1 Like

Well I’m back. :frowning: and with sad news: flash failed.

First, since I couldn’t use my corporate-issued mac I had to use my husband’s windows machine. I had long ago given up on being his IT support so I was shocked to learn he had Windows 7, so got that updated to 10, installed Balena and followed the instructions like you mentioned.

The message was: flash failed. Do you think it’s because I already tried this earlier? Should I just reformat the SD card?

Oh, maybe I should try it anyway, seeing a similar flash failed issue on another thread, so let me try that and get back to you. Also, if you want me to update the docs with that alternative way to flash and SD, I’m happy to do so, just ping me and I’ll help.

Try using various flashing software. Rufus, dd, there are lots.

Ok, thanks nick. I’ll try that. I stuck the SD card in the PI and it’s still not showing up in the network. I’ve never done this before so unsure what to look for/expect. It’s odd how the SD card adapter is really tight but the slot on the pi is not, so I was worried I hadn’t seated it in there correctly, but there’s really only one way. :slightly_frowning_face:

Get that monitor out!

When connecting the monitor, I just see an empty Pi with “Unable to read partition…” messages.
Am I also supposed to first install the raspberry pi os? I didn’t think so. I think the flash failed.
Also, dd is on ubuntu and we don’t have a linux machine here
rufus has a few options to flash… including select bootable. I guess I can try that. I tried Balena Etcher twice and it looked like it succeeded but the validation fails.

I wouldn’t bother with inserting it into the pi or using an HDMI cable if Balena is telling you the flash failed. You can try to format it first, but disk imaging software doesn’t usually care what’s on the disk - they are burning the image to it regardless of whether it’s formatted or not. The other free imaging software I’ve used is Win32 Disk Imager.

What brand and size is the SD card you are using? It sounds to me like it may be defective. They are cheap enough that I would have several on hand to try. You can use any spares to create a bootable backup by cloning your Home Assistant once it’s all up and working.

Yes, the formatting and indeed partitioning is in the image.

@prose you could try dd on your Mac, or run ubuntu via a usb stick on the windows machine. It won’t hurt it :slight_smile:

thanks mightyboss. I think you are right that it’s defective. I decided to stick it in my Chromebook and follow instructions here about how to flash media that way, since my Chromebook is newer and has an SD reader (trying to eliminate possibility of defective reader on the windows machine). When I did so, got a message that the SD card had 7GB on it! Wut? It’s supposed to be much more 64…GB. So I ordered a couple more and we’ll see.

@nickrout can’t use my mac as it’s a corp machine and I get access blocked.

Yeah I wasn’t sure how locked down it was.

That 7Gb is probably what’s left-over from the main partition. On a windows computer run the command compmgmt.msc and select ‘Storage - Disk Management’ where you can see the partitions. Delete them and format it as one partition on Windows, then re-try the flash from a local file.

If Balena fails, try Raspberry Pi Imager

Thanks for your help, everyone! I got that thing up and running. I just got a new card. And some extras. Now for the fun part!

1 Like