Raspberry pi not visible on LAN after sdcard installation

Hi, I have just flashed hass.io on to a 16GB class A1 sd card. I read somewhere here in the community that 16GB would be fine although the requirements says 32GB and recommend class A2… How ever after flashing and inserting the sd card in my raspberry pi 3 B and turning it on, nothing happens.

The LED on the pi lights up red, but the indication light on the ethernet port is completely inactive. the same goes for the indication LED on the routers ethernet port where the pi is connect, zero light. I’m 100% sure the cable is working fine, I have switched between several cables from my other devices which both blinks and are visible on my LAN.

I though something might have gone wrong with the flashing so I also tried reflashing the sd card, once again. But exactly same result, nothing happens and the pi wont show up on my netwok.

I used this image: * Raspberry Pi 3 Model B and B+ 32-bit (32-bit is required for GPIO support)

Any ideas what might be wrong ?

What did you use to burn the image to the card?

Balena Etcher

Now I have also tried booting the pi up with a different sdcard that has raspbian flashed onto it, and that boots up fine and and becomes visible on the network. So it’s also not the pi that is something wrong with. Also just tested the sd card with h2testw and it didn’t find any error on the card. write speed 10MBps read speed 20MBps…

I have now just received a new 32GB sd card in the mail. I have flashed the image onto that brand new card using the latest version of BalenaEtcher. Once again, exactly nothing happens when I turn on the pi. the ethernet indication led doesn’t blink a single time.

What can I do next ? Are there older images available somewhere that I could download and try? I have had hassio running on the same pi about a year ago, i am cluesless to why it is impossible to get installed now.

I am having the same issue. Most community posts on this matter never seemed to fix the problem. Were you able to resolve it?

Just had this problem, just slight different timing. HA has been working fine for me for many months, but a few days ago the lights on the ethernet port went out and it’s been unreachable since. I’ve tried unplugging and replugging in the ethernet cable as well as turning the pi on and off but neither have helped. Pi 3B btw.

Yesterday updated the Raspberry PI 2 to the latest version minor version. After the reboot the PI was online, however Home Assistant was not running. After a second reboot the PI failed to come online. Exact same symptoms as described in thread. The power indicator of the PI is turned on (red light), however the network never comes online. No lights on or blinking at the network port. Trying to resolve the situation, however, I think I will need to re-install home assistant from scratch.

And nobody ever connected a monitor to check for any error messges or something?

Yes, trying that now. Monitor displays no signal. Trying now various configuration options in the config.txt on the SD card.

Edit: meanwhile, any settings that I try to change in config.txt don’t stick. It appears the SD card might be stuck in read-only mode. It appears an SD card will do this when it becomes old, damaged, etc. The card will hardware lock itself in to read-only to prevent further damage and allowing you to copy all the data. I will see if I can clone the entire card as-is and restore it on a new SD card to see if this actually was the problem and solution.

Edit: cloning the micro SD card did not work. I got error while trying with Rufus, Win32DiskImager and balenaEtcher. Now busy setting up a new micro SD card with a fresh copy of Home Assistant.

same problem here. the red led will blink 1 times, nothing happens.
on my monitor is the text, no connection to hdmi

To me that sounds like the raspi doesn’t start up at all…checked powersupply? (maybe try a more powerful one?)

There have been a few posts on other boards recently about eth0 becoming disabled on pi3’s and Wifi only being useable, and in one of my units this seems to be the case. But my HDMI was working so I could configure this.

starting a io broker installation with the same sd card and powersupply has no problems.

i have a pi 3b without +, so there is no wifi on this thing :frowning:

I have the exact same problem. Home Assistant has been working fine for three years, then suddenly I cannot connect to it. Upon checking the LED indicators in the ethernet port I noticed they were very dim, almost completely off.

same here . Any news on this?