Raspberry Pi with Home Assistant OS won't boot twice

I am very new to this and not great at all this programming.
I followed these instructions
successfully and was able to find and set up some new devices I have in my home, via homeassistant.local:8123.
HOWEVER, when I powered off the Raspberry Pi to move it to a new location (after I had done my testing and learning!) I was unable to reconnect using homeassistant.local:8123.
If I reflash the SD card, I can connect again. But each time after a power off, I can’t get back in.

I have tried this four or five times…each time the reflashing works, but that’s not sustainable.

Any advice?
Many thanks.

Can you connect a monitor and keyboard to the pi to see why it won’t boot?

Thanks for the quick reply. I tried that night and the monitor reported “No signal”.
I tried both HDMI ports.
When I first flashed the pi last week, I was able to see the lines of code scrolling on the monitor as it loaded the HASS OS. But last night, I got nothing.

Note: while I said that the pi won’t boot - I’m just assuming that’s what’s happening. All I know is that I “can’t reach this page” when I open homeassistant.local:8123.

I’ll try the monitor and keyboard again and report back.

A related question: Is it ‘safe’ to power off the pi by just removing the power? When I did have connection to the Home Assistant, I was able to Shutdown the Host via the Supervisor tab.

Was this correct? Is there a chance that this is the cause of my problem

No, this can lead to SD card corruption. Shutdown the host (supervisor system panel) before removing power.

Thanks - how can I tell when the pi has shut down? Green light stops blinking?
Note: The green light is off at present - after the second boot (which doesn’t work).

Yeah the green light is the SD card activity light.

I had similar issues and it turned out to be the sd card, after that I decided to get a ssd.

SSD = Solid state device? i.e. a USB stick?

I have two brand new systems (planning to set up HASS for house alarms for myself and my brother).
Both are behaving in the same way, which leads me to believe that the hardware isn’t the problem. The SD cards are SanDisk, which should be reliable.

No, they are not long-term. You’ll find countless of posts here on the forum on failed SD cards, no matter how expensive they were.

I’ve just had the chance to plug in a keyboard and monitor. The keyboard caps lock light does come on, but the monitor says no signal. I have left it for twenty minutes at this stage.
I can reflash and get it going again, but I can’t have to do that if I ever get a power cut.

What else can I do to workout why I can’t shutdown and restart the pi with hass os?

When you reflash and start over again, can you see it come up properly via the monitor? Seems like something in the boot/start sequence is corrupting something causing the subsequent boot to fail. That could be the SD card failing with partitioning, updates, /tmp usage etc. Any way to try a different card?

Its seems your HA failed to restart, unsure why. Recommended to move away from microSD and used SSD instead. Since RPI support USB Bootable SSD, the setup is as simple as making a microSD boot disk.

Thanks to all suggesting fixes. Am I to ignore the detail in the first link? And follow the instructions in the second link?

To answer another question, I have two brand new pis and two brand new sd cards. Both are behaving the same way.
I’ll try reflashing and connecting to a monitor tomorrow.

You can also ping it from another computer on your network. When the ping fails it is off. I.e ping 192.168.1.xx /t. Also not sure if you tried a shutdown and a restart prior to moving the pi. Your issue maybe network related.

Thanks Bill. I like the sound of that…considering that I have two RPIs acting the same way, I think it’s more likely that it could be a network problem.
Apologies for what is probably the most basic of questions, but how do I find out what the xx is (i.e. The full address of the RPI)?

You need your pi’s up address. You can find it on your router, with one of many programs that can scan your network for devices, I.e Fling or when you have access (your first boot while it is working) supervisor, host. You can also change your settings there. Are you using WiFi or wired connection?

Thanks to all for your advice.
I believe my trouble was related to connecting to different routers that I have. I have a Huawei as my access point into the house which is hardwired to a port extender which connects the LAN to all the rooms, including a TP-Link router in the living room, which acts as the wifi point for the downstairs of the house. When I plugged the RPI into the port extender and was trying to connect to the Home Assistant interface using the TP-Link wifi - it couldn’t be seen.

So, things seem to be working okay now. Having said that, when I was reflashing and testing a reboot, I didn’t get any signal at all on the HDMI output.

So, apart from that lack of a screen, which I’m not overly concerned with (the RPI will be only to run HASS for an alarm system (and maybe some lights etc as I expand)) the problem now is that the Home Assistant Interface (home.assistant.local:8123) can’t see devices that are connected to my home network via the downstairs TP-Link wifi. Is there a setting that needs to be en/disabled to allow HASS see ‘through’ the router?

p.s. I will change and boot via USB as soon as I can get the hardware.

I have figured it out. DHCP was the key (assuming I was correct).
Thanks again to all.

Hopefully, the RPI will handle rebooting (e.g. after a power outage) and that I won’t need to hook it to a monitor!