Raspberry PI3B HassOs Instalaltion Problem

Hi have been trying to do fresh installation of Hassio on Raspberry PI3B 32bit edition from latest image. Every time I tried it waits at hassio splash screen with message “(this can take up to 20 minutes)”. Last installation has been waiting for almost 20 hours and I have no idea to login and check any status or reason. I tried to ping local IP and getting response from PI server in average 7ms. For wifi I used a USB drive with network configuration on PI usb port and using a 32GB card imaged using Etcher.

Any help appreciated.


1 Like

You won’t see anything on the raspberry HDMI video out. Home Assistant is accessible via http://<rpi_ip_address>:8123 on another machine on the same network.

Yes, what I described here was from and it was configured to use fixed IP from where I am getting ping response. Thx

Ahhh… Sorry…

Try to access it from a different browser using incognito mode.

It is still showing same 20 minute wait screen in incognito mode and even from a different tablet. I tried both Edge and Chrome browsers. Thx

My installation took about 2 hours to complete. Try to CTRL+F5 to refresh the page.

I tried wired network connection and left it for whole night but did not work. It stayed on the same 20 minute wait screen. After that I tried to power off and on but did not boot. I am not sure what to do next.

It sounds like an Internet connectivity problem to me…

I tried even tried with wired connection and situation stayed the same. This time I created two files under network folder with below information on USB drive labelled CONFIG. One uses my guest wifi while other file uses main wifi network ID :













I created two separate UUID in both files assuming it will use one of them and I am able to ping pi server at and wait screen is at on the same LAN.

When I say Internet problem I am not referring to the ethernet of WiFi network but your internet connection… (mind you it could of course be a WiFi issue)

should that be not 213??? Are you sure 214 isn’t the IP address of some other device??

You should not need to specify a network file to set up Hassio on the Pi if it’s a wired connection. It doesn’t need it.

I have no complain of internet from any of the device at my home and on the same PI if I place old hassio version 0.71 SD card it works perfectly however new image of hassOS is giving trouble.

IP is reserved at router for wifi mac address and I am trying to assign manually for wired LAN. Placing both entries in config file means it will have option to pick any wired or wifi.

Next I will try wired connection and no network file/ no usb config device. Thx

I tried wired connection with router and no network CONFIG on USB drive but situation remains the same. It is getting stuck at splash screen with message “this can take up to 20 minutes”. It is getting fixed IP reserved from router based on MAC. I don’t see any reason with internet access however I suspect its ability to connect to GitHub site to get update. I am direction less now.

I have been able to make some progress after connecting monitor to HDMI port. I did not know that HASSOS will give video output during install and what I noticed from my installation:

  1. During boot RP3 was complaining about “Under voltage detected!” that was probably because I was using power bar USB port with micro USB cable and it started giving too many errors during installation. I restarted the process with original power adapter that came with RPI3. (It seems very important to have right power supply)
  2. Installation was getting stuck at below red marked location in snapshot. It moved forward only when I pulled out USB network CONFIG drive (Not sure if it is a mandatory step but this is the only way it progressed and could start processes 9 & 10)
    [ 306.826127] usb 1-1.5: USB disconnect, device number 4
    [ 664.740329] udevd[9]: starting version 3.2.5
    [ 664.740329] udevd[10]: starting eudev-3.2.5
  3. I have completed the installation and it has detected one switch and few other things at my home but problem is is not loading (all other menu options are loading) and I am not able to move forward with my homeassistant configuration

Not sure what to do next, no way to start or stop HASSOS!

Go ti that terminal on the hdmi monitor with usb keyboard and run

hassio ha update

Reboot the pi, clear your browsers cache

I logged in as root and when I executed the command it returned me below error:

haasio > ha update
The HTTP request failed with the error: Post http://hassio/homeassistant/update: dial tcp getsockopt: connection refused

In fact I am getting same error for other ha and host commands. When I logged in as root it did not ask for password. What is the default password for root?

I am experiencing similar problem. I have used Etcher to put the Hass.IO 1.9 32bit image on a 16GB samsung micro sd card [Raspberry 3b 1.2] and I get the message “this can take up to 20 minutes”. I left it during night (~10hours) and still nothing! One time I tried to attach it to a monitor and got to the login part. Now it doesn’t show anything on the hdmi output, just the same why page saying “Preparing… This can take up to 20 minutes”
I now tried to format the card in Linux but the partitions don’t seem to like to be deleted. They come back right after.

What’s going on ? Why can’t I format the card anymore, after flashing the Hass.io image ???

Hassio dashboard was actually broken in the image, multiple people complaining the same. You can find more details at https://github.com/home-assistant/home-assistant/issues/15816

I installed the recently released HASSOS image for 0.75.2 hassos_rpi3-1.9.img.gz for Raspberry PI3B and it worked well.

The problem is that I’m not sure how to re-flash anything over the card I used because I already tried to delete all partitions and even reflashing raspbian stretch over it and it fails! The hassio partitions come back right after I eject and plug the card in.
How can I delete them ?

Use MiniToolPartitionWizard to delete all partitions on the card and then create one new one and then make sure you click APPLY and it should create one partition. Then use etcher to image it. (make sure it’s the latest etcher)

I’ve tried from gparted (linux) to diskpart (win) … everything fails. I mean, It shows ‘success’ on deleting the partitions, but then it fails on creating a new one. I then eject the card and load it again, and hassio partitions are back!
Etcher on linux even said that it wrote the raspbian stretch image successfully, but guess what, after replugging the sd-card, hassio partitions were still there!
I was thinking that hassio image could have somehow corrupted the sdcard, however, if i put it on the raspberry, it boots and reaches the “Welcome to Hassio” (login input). Is there anything on the hassio that prevents one from re-flashing the card (security related) ?