Raspberry Pi4 ethernet not working ( only WiFi works)


I am fairly new to home assistant, Raspberry Pi and networking.
I was previously using my Installation on a wifi setup, and tried to connect it using a LAN port from my switch but no ip address was assigned to the instance.
Here are the few things that i have tried.

  1. Did a fresh install and connected lan, the cli load shows on the screen, but with no ip address for eth0.
    2.Tried different cat5e cables, i am not sure how different are the cables i tried, nothing made a difference. I can find the device on my switch/network but no ip is assigned as well.

  2. Tried giving a static ip, not working.

  3. Connected the ethernet to other devices ( windows 10 laptop), the ethernet works fine, so i assume its not the switch causing the issue.

But, things works if I put in the my-network config file with settings for wifi
I am using a full unifi network setup, every other device work except for the pi :frowning:

Any help regarding this is appreciated,
Thank you!!

Same here (RPi4, no IP address via ethernet, over wifi it’s working, full Unifi network).
Did you get this issue resolved?

After a frustating day searching for solutions, I got my ethernet connection working again by issueing the following command:

/sbin/ethtool -s eth0 speed 100 duplex full autoneg off

See 14.04 - Network eth0 DHCP, static ip and autonegotiation issues - Ask Ubuntu (also to make this setting persistent)